TAP version 13 not ok 1 - debug v4.1.1 Install Failed ---
# > phantomjs-prebuilt@2.1.16 install /tmp/b92a2b7c-d6e9-453b-826e-f9b2b359535f/debug/node_modules/phantomjs-prebuilt
# > node install.js
# PhantomJS not found on PATH
# debug@4.1.1 /tmp/b92a2b7c-d6e9-453b-826e-f9b2b359535f/debug
# +-- @babel/cli@7.4.3
# | +-- chokidar@2.1.5
# | | +-- anymatch@2.0.0
# | | | +-- micromatch@3.1.10
# | | | | +-- arr-diff@4.0.0
# | | | | +-- define-property@2.0.2
# | | | | | `-- is-descriptor@1.0.2
# | | | | | +-- is-accessor-descriptor@1.0.0
# | | | | | `-- is-data-descriptor@1.0.0
# | | | | +-- extend-shallow@3.0.2
# | | | | | +-- assign-symbols@1.0.0
# | | | | | `-- is-extendable@1.0.1
# | | | | +-- extglob@2.0.4
# | | | | | +-- define-property@1.0.0
# | | | | | | `-- is-descriptor@1.0.2
# | | | | | | +-- is-accessor-descriptor@1.0.0
# | | | | | | `-- is-data-descriptor@1.0.0
# | | | | | +-- expand-brackets@2.1.4
# | | | | | | +-- define-property@0.2.5
# | | | | | | +-- extend-shallow@2.0.1
# | | | | | | `-- posix-character-classes@0.1.1
# | | | | | `-- extend-shallow@2.0.1
# | | | | +-- fragment-cache@0.2.1
# | | | | +-- kind-of@6.0.2
# | | | | +-- nanomatch@1.2.13
# | | | | | `-- is-windows@1.0.2
# | | | | +-- object.pick@1.3.0
# | | | | `-- regex-not@1.0.2
# | | | `-- normalize-path@2.1.1
# | | | `-- remove-trailing-separator@1.1.0
# | | +-- async-each@1.0.3
# | | +-- braces@2.3.2
# | | | +-- arr-flatten@1.1.0
# | | | +-- array-unique@0.3.2
# | | | +-- extend-shallow@2.0.1
# | | | | `-- is-extendable@0.1.1
# | | | +-- fill-range@4.0.0
# | | | | +-- extend-shallow@2.0.1
# | | | | +-- is-number@3.0.0
# | | | | | `-- kind-of@3.2.2
# | | | | +-- repeat-string@1.6.1
# | | | | `-- to-regex-range@2.1.1
# | | | +-- isobject@3.0.1
# | | | +-- repeat-element@1.1.3
# | | | +-- snapdragon@0.8.2
# | | | | +-- base@0.11.2
# | | | | | +-- cache-base@1.0.1
# | | | | | | +-- collection-visit@1.0.0
# | | | | | | | +-- map-visit@1.0.0
# | | | | | | | `-- object-visit@1.0.1
# | | | | | | +-- get-value@2.0.6
# | | | | | | +-- has-value@1.0.0
# | | | | | | | `-- has-values@1.0.0
# | | | | | | | `-- kind-of@4.0.0
# | | | | | | +-- set-value@2.0.0
# | | | | | | | `-- extend-shallow@2.0.1
# | | | | | | +-- to-object-path@0.3.0
# | | | | | | | `-- kind-of@3.2.2
# | | | | | | +-- union-value@1.0.0
# | | | | | | | `-- set-value@0.4.3
# | | | | | | | `-- extend-shallow@2.0.1
# | | | | | | `-- unset-value@1.0.0
# | | | | | | `-- has-value@0.3.1
# | | | | | | +-- has-values@0.1.4
# | | | | | | `-- isobject@2.1.0
# | | | | | +-- class-utils@0.3.6
# | | | | | | +-- arr-union@3.1.0
# | | | | | | +-- define-property@0.2.5
# | | | | | | `-- static-extend@0.1.2
# | | | | | | +-- define-property@0.2.5
# | | | | | | `-- object-copy@0.1.0
# | | | | | | +-- copy-descriptor@0.1.1
# | | | | | | +-- define-property@0.2.5
# | | | | | | `-- kind-of@3.2.2
# | | | | | +-- component-emitter@1.3.0
# | | | | | +-- define-property@1.0.0
# | | | | | | `-- is-descriptor@1.0.2
# | | | | | | +-- is-accessor-descriptor@1.0.0
# | | | | | | `-- is-data-descriptor@1.0.0
# | | | | | +-- mixin-deep@1.3.1
# | | | | | | +-- for-in@1.0.2
# | | | | | | `-- is-extendable@1.0.1
# | | | | | `-- pascalcase@0.1.1
# | | | | +-- define-property@0.2.5
# | | | | | `-- is-descriptor@0.1.6
# | | | | | +-- is-accessor-descriptor@0.1.6
# | | | | | | `-- kind-of@3.2.2
# | | | | | +-- is-data-descriptor@0.1.4
# | | | | | | `-- kind-of@3.2.2
# | | | | | `-- kind-of@5.1.0
# | | | | +-- extend-shallow@2.0.1
# | | | | +-- map-cache@0.2.2
# | | | | +-- source-map-resolve@0.5.2
# | | | | | +-- atob@2.1.2
# | | | | | +-- decode-uri-component@0.2.0
# | | | | | +-- resolve-url@0.2.1
# | | | | | +-- source-map-url@0.4.0
# | | | | | `-- urix@0.1.0
# | | | | `-- use@3.1.1
# | | | +-- snapdragon-node@2.1.1
# | | | | +-- define-property@1.0.0
# | | | | | `-- is-descriptor@1.0.2
# | | | | | +-- is-accessor-descriptor@1.0.0
# | | | | | `-- is-data-descriptor@1.0.0
# | | | | `-- snapdragon-util@3.0.1
# | | | | `-- kind-of@3.2.2
# | | | +-- split-string@3.1.0
# | | | `-- to-regex@3.0.2
# | | +-- glob-parent@3.1.0
# | | | +-- is-glob@3.1.0
# | | | `-- path-dirname@1.0.2
# | | +-- is-binary-path@1.0.1
# | | | `-- binary-extensions@1.13.1
# | | +-- is-glob@4.0.1
# | | | `-- is-extglob@2.1.1
# | | +-- normalize-path@3.0.0
# | | +-- path-is-absolute@1.0.1
# | | +-- readdirp@2.2.1
# | | `-- upath@1.1.2
# | +-- commander@2.20.0
# | +-- convert-source-map@1.6.0
# | +-- fs-readdir-recursive@1.1.0
# | +-- glob@7.1.3
# | | +-- fs.realpath@1.0.0
# | | `-- inflight@1.0.6
# | +-- lodash@4.17.11
# | +-- mkdirp@0.5.1
# | | `-- minimist@0.0.8
# | +-- output-file-sync@2.0.1
# | | `-- is-plain-obj@1.1.0
# | +-- slash@2.0.0
# | `-- source-map@0.5.7
# +-- @babel/core@7.4.3
# | +-- @babel/code-frame@7.0.0
# | | `-- @babel/highlight@7.0.0
# | | `-- js-tokens@4.0.0
# | +-- @babel/generator@7.4.0
# | | +-- jsesc@2.5.2
# | | `-- trim-right@1.0.1
# | +-- @babel/helpers@7.4.3
# | +-- @babel/parser@7.4.3
# | +-- @babel/template@7.4.0
# | +-- @babel/traverse@7.4.3
# | | +-- @babel/helper-function-name@7.1.0
# | | +-- @babel/helper-split-export-declaration@7.4.0
# | | +-- debug@4.1.1
# | | `-- globals@11.11.0
# | +-- @babel/types@7.4.0
# | | +-- esutils@2.0.2
# | | `-- to-fast-properties@2.0.0
# | +-- debug@4.1.1
# | +-- json5@2.1.0
# | | `-- minimist@1.2.0
# | +-- resolve@1.10.1
# | | `-- path-parse@1.0.6
# | `-- semver@5.7.0
# +-- @babel/preset-env@7.4.3
# | +-- @babel/helper-module-imports@7.0.0
# | +-- @babel/helper-plugin-utils@7.0.0
# | +-- @babel/plugin-proposal-async-generator-functions@7.2.0
# | | `-- @babel/helper-remap-async-to-generator@7.1.0
# | | `-- @babel/helper-wrap-function@7.2.0
# | +-- @babel/plugin-proposal-json-strings@7.2.0
# | +-- @babel/plugin-proposal-object-rest-spread@7.4.3
# | +-- @babel/plugin-proposal-optional-catch-binding@7.2.0
# | +-- @babel/plugin-proposal-unicode-property-regex@7.4.0
# | | +-- @babel/helper-regex@7.4.3
# | | `-- regexpu-core@4.5.4
# | | +-- regenerate@1.4.0
# | | +-- regenerate-unicode-properties@8.0.2
# | | +-- regjsgen@0.5.0
# | | +-- regjsparser@0.6.0
# | | | `-- jsesc@0.5.0
# | | +-- unicode-match-property-ecmascript@1.0.4
# | | | +-- unicode-canonical-property-names-ecmascript@1.0.4
# | | | `-- unicode-property-aliases-ecmascript@1.0.5
# | | `-- unicode-match-property-value-ecmascript@1.1.0
# | +-- @babel/plugin-syntax-async-generators@7.2.0
# | +-- @babel/plugin-syntax-json-strings@7.2.0
# | +-- @babel/plugin-syntax-object-rest-spread@7.2.0
# | +-- @babel/plugin-syntax-optional-catch-binding@7.2.0
# | +-- @babel/plugin-transform-arrow-functions@7.2.0
# | +-- @babel/plugin-transform-async-to-generator@7.4.0
# | +-- @babel/plugin-transform-block-scoped-functions@7.2.0
# | +-- @babel/plugin-transform-block-scoping@7.4.0
# | +-- @babel/plugin-transform-classes@7.4.3
# | | +-- @babel/helper-annotate-as-pure@7.0.0
# | | +-- @babel/helper-define-map@7.4.0
# | | +-- @babel/helper-optimise-call-expression@7.0.0
# | | `-- @babel/helper-replace-supers@7.4.0
# | | `-- @babel/helper-member-expression-to-functions@7.0.0
# | +-- @babel/plugin-transform-computed-properties@7.2.0
# | +-- @babel/plugin-transform-destructuring@7.4.3
# | +-- @babel/plugin-transform-dotall-regex@7.4.3
# | +-- @babel/plugin-transform-duplicate-keys@7.2.0
# | +-- @babel/plugin-transform-exponentiation-operator@7.2.0
# | | `-- @babel/helper-builder-binary-assignment-operator-visitor@7.1.0
# | | `-- @babel/helper-explode-assignable-expression@7.1.0
# | +-- @babel/plugin-transform-for-of@7.4.3
# | +-- @babel/plugin-transform-function-name@7.4.3
# | +-- @babel/plugin-transform-literals@7.2.0
# | +-- @babel/plugin-transform-member-expression-literals@7.2.0
# | +-- @babel/plugin-transform-modules-amd@7.2.0
# | | `-- @babel/helper-module-transforms@7.4.3
# | +-- @babel/plugin-transform-modules-commonjs@7.4.3
# | | `-- @babel/helper-simple-access@7.1.0
# | +-- @babel/plugin-transform-modules-systemjs@7.4.0
# | | `-- @babel/helper-hoist-variables@7.4.0
# | +-- @babel/plugin-transform-modules-umd@7.2.0
# | +-- @babel/plugin-transform-named-capturing-groups-regex@7.4.2
# | | `-- regexp-tree@0.1.5
# | +-- @babel/plugin-transform-new-target@7.4.0
# | +-- @babel/plugin-transform-object-super@7.2.0
# | +-- @babel/plugin-transform-parameters@7.4.3
# | | +-- @babel/helper-call-delegate@7.4.0
# | | `-- @babel/helper-get-function-arity@7.0.0
# | +-- @babel/plugin-transform-property-literals@7.2.0
# | +-- @babel/plugin-transform-regenerator@7.4.3
# | | `-- regenerator-transform@0.13.4
# | | `-- private@0.1.8
# | +-- @babel/plugin-transform-reserved-words@7.2.0
# | +-- @babel/plugin-transform-shorthand-properties@7.2.0
# | +-- @babel/plugin-transform-spread@7.2.2
# | +-- @babel/plugin-transform-sticky-regex@7.2.0
# | +-- @babel/plugin-transform-template-literals@7.2.0
# | +-- @babel/plugin-transform-typeof-symbol@7.2.0
# | +-- @babel/plugin-transform-unicode-regex@7.4.3
# | +-- browserslist@4.5.5
# | | +-- caniuse-lite@1.0.30000963
# | | +-- electron-to-chromium@1.3.127
# | | `-- node-releases@1.1.17
# | +-- core-js-compat@3.0.1
# | | +-- core-js@3.0.1
# | | +-- core-js-pure@3.0.1
# | | `-- semver@6.0.0
# | +-- invariant@2.2.4
# | | `-- loose-envify@1.4.0
# | `-- js-levenshtein@1.1.6
# +-- browserify@14.4.0
# | +-- assert@1.4.1
# | | `-- util@0.10.3
# | | `-- inherits@2.0.1
# | +-- browser-pack@6.1.0
# | | +-- combine-source-map@0.8.0
# | | | +-- convert-source-map@1.1.3
# | | | +-- inline-source-map@0.6.2
# | | | `-- lodash.memoize@3.0.4
# | | `-- umd@3.0.3
# | +-- browser-resolve@1.11.3
# | | `-- resolve@1.1.7
# | +-- browserify-zlib@0.1.4
# | | `-- pako@0.2.9
# | +-- buffer@5.2.1
# | | +-- base64-js@1.3.0
# | | `-- ieee754@1.1.13
# | +-- cached-path-relative@1.0.2
# | +-- concat-stream@1.5.2
# | | +-- readable-stream@2.0.6
# | | | +-- process-nextick-args@1.0.7
# | | | `-- string_decoder@0.10.31
# | | `-- typedarray@0.0.6
# | +-- console-browserify@1.1.0
# | | `-- date-now@0.1.4
# | +-- constants-browserify@1.0.0
# | +-- crypto-browserify@3.12.0
# | | +-- browserify-cipher@1.0.1
# | | | +-- browserify-aes@1.2.0
# | | | | `-- buffer-xor@1.0.3
# | | | +-- browserify-des@1.0.2
# | | | | `-- des.js@1.0.0
# | | | `-- evp_bytestokey@1.0.3
# | | +-- browserify-sign@4.0.4
# | | | +-- bn.js@4.11.8
# | | | +-- browserify-rsa@4.0.1
# | | | +-- elliptic@6.4.1
# | | | | +-- brorand@1.1.0
# | | | | +-- hash.js@1.1.7
# | | | | +-- hmac-drbg@1.0.1
# | | | | +-- minimalistic-assert@1.0.1
# | | | | `-- minimalistic-crypto-utils@1.0.1
# | | | `-- parse-asn1@5.1.4
# | | | `-- asn1.js@4.10.1
# | | +-- create-ecdh@4.0.3
# | | +-- create-hash@1.2.0
# | | | +-- cipher-base@1.0.4
# | | | +-- md5.js@1.3.5
# | | | | `-- hash-base@3.0.4
# | | | `-- ripemd160@2.0.2
# | | +-- create-hmac@1.1.7
# | | +-- diffie-hellman@5.0.3
# | | | `-- miller-rabin@4.0.1
# | | +-- pbkdf2@3.0.17
# | | +-- public-encrypt@4.0.3
# | | +-- randombytes@2.1.0
# | | `-- randomfill@1.0.4
# | +-- defined@1.0.0
# | +-- deps-sort@2.0.0
# | +-- domain-browser@1.1.7
# | +-- duplexer2@0.1.4
# | +-- events@1.1.1
# | +-- has@1.0.3
# | | `-- function-bind@1.1.1
# | +-- htmlescape@1.1.1
# | +-- https-browserify@1.0.0
# | +-- inherits@2.0.3
# | +-- insert-module-globals@7.2.0
# | | +-- acorn-node@1.6.2
# | | | +-- acorn@6.1.1
# | | | +-- acorn-dynamic-import@4.0.0
# | | | `-- acorn-walk@6.1.1
# | | +-- concat-stream@1.6.2
# | | | `-- buffer-from@1.1.1
# | | +-- is-buffer@1.1.6
# | | `-- undeclared-identifiers@1.1.3
# | | +-- dash-ast@1.0.0
# | | +-- get-assigned-identifiers@1.2.0
# | | `-- simple-concat@1.0.0
# | +-- JSONStream@1.3.5
# | | +-- jsonparse@1.3.1
# | | `-- through@2.3.8
# | +-- labeled-stream-splicer@2.0.1
# | | +-- isarray@2.0.4
# | | `-- stream-splicer@2.0.0
# | +-- module-deps@4.1.1
# | | +-- detective@4.7.1
# | | | `-- acorn@5.7.3
# | | `-- stream-combiner2@1.1.1
# | +-- os-browserify@0.1.2
# | +-- parents@1.0.1
# | | `-- path-platform@0.11.15
# | +-- path-browserify@0.0.1
# | +-- process@0.11.10
# | +-- punycode@1.4.1
# | +-- querystring-es3@0.2.1
# | +-- read-only-stream@2.0.0
# | +-- readable-stream@2.3.6
# | | +-- core-util-is@1.0.2
# | | +-- isarray@1.0.0
# | | +-- process-nextick-args@2.0.0
# | | +-- string_decoder@1.1.1
# | | `-- util-deprecate@1.0.2
# | +-- shasum@1.0.2
# | | +-- json-stable-stringify@0.0.1
# | | `-- sha.js@2.4.11
# | +-- shell-quote@1.6.1
# | | +-- array-filter@0.0.1
# | | +-- array-map@0.0.0
# | | +-- array-reduce@0.0.0
# | | `-- jsonify@0.0.0
# | +-- stream-browserify@2.0.2
# | +-- stream-http@2.8.3
# | | +-- builtin-status-codes@3.0.0
# | | `-- to-arraybuffer@1.0.1
# | +-- string_decoder@1.0.3
# | +-- subarg@1.0.0
# | | `-- minimist@1.2.0
# | +-- syntax-error@1.4.0
# | +-- through2@2.0.5
# | +-- timers-browserify@1.4.2
# | +-- tty-browserify@0.0.1
# | +-- url@0.11.0
# | | +-- punycode@1.3.2
# | | `-- querystring@0.2.0
# | +-- util@0.10.4
# | +-- vm-browserify@0.0.4
# | | `-- indexof@0.0.1
# | `-- xtend@4.0.1
# +-- chai@3.5.0
# | +-- assertion-error@1.1.0
# | +-- deep-eql@0.1.3
# | | `-- type-detect@0.1.1
# | `-- type-detect@1.0.0
# +-- concurrently@3.6.1
# | +-- chalk@2.4.2
# | | +-- ansi-styles@3.2.1
# | | | `-- color-convert@1.9.3
# | | | `-- color-name@1.1.3
# | | `-- supports-color@5.5.0
# | +-- commander@2.6.0
# | +-- date-fns@1.30.1
# | +-- read-pkg@3.0.0
# | | +-- load-json-file@4.0.0
# | | | +-- parse-json@4.0.0
# | | | | +-- error-ex@1.3.2
# | | | | | `-- is-arrayish@0.2.1
# | | | | `-- json-parse-better-errors@1.0.2
# | | | `-- strip-bom@3.0.0
# | | +-- normalize-package-data@2.5.0
# | | | +-- hosted-git-info@2.7.1
# | | | `-- validate-npm-package-license@3.0.4
# | | | +-- spdx-correct@3.1.0
# | | | | `-- spdx-license-ids@3.0.4
# | | | `-- spdx-expression-parse@3.0.0
# | | | `-- spdx-exceptions@2.2.0
# | | `-- path-type@3.0.0
# | +-- rx@2.3.24
# | +-- spawn-command@0.0.2-1
# | +-- supports-color@3.2.3
# | | `-- has-flag@1.0.0
# | `-- tree-kill@1.2.1
# +-- coveralls@3.0.3
# | +-- growl@1.10.5
# | +-- js-yaml@3.13.1
# | | +-- argparse@1.0.10
# | | | `-- sprintf-js@1.0.3
# | | `-- esprima@4.0.1
# | +-- lcov-parse@0.0.10
# | +-- log-driver@1.2.7
# | +-- minimist@1.2.0
# | `-- request@2.88.0
# | +-- aws-sign2@0.7.0
# | +-- aws4@1.8.0
# | +-- caseless@0.12.0
# | +-- combined-stream@1.0.7
# | | `-- delayed-stream@1.0.0
# | +-- extend@3.0.2
# | +-- forever-agent@0.6.1
# | +-- form-data@2.3.3
# | | `-- asynckit@0.4.0
# | +-- har-validator@5.1.3
# | | `-- har-schema@2.0.0
# | +-- http-signature@1.2.0
# | | +-- assert-plus@1.0.0
# | | +-- jsprim@1.4.1
# | | | +-- extsprintf@1.3.0
# | | | +-- json-schema@0.2.3
# | | | `-- verror@1.10.0
# | | `-- sshpk@1.16.1
# | | +-- asn1@0.2.4
# | | +-- bcrypt-pbkdf@1.0.2
# | | +-- dashdash@1.14.1
# | | +-- ecc-jsbn@0.1.2
# | | +-- getpass@0.1.7
# | | +-- jsbn@0.1.1
# | | `-- tweetnacl@0.14.5
# | +-- is-typedarray@1.0.0
# | +-- isstream@0.1.2
# | +-- json-stringify-safe@5.0.1
# | +-- mime-types@2.1.24
# | | `-- mime-db@1.40.0
# | +-- oauth-sign@0.9.0
# | +-- performance-now@2.1.0
# | +-- qs@6.5.2
# | +-- tough-cookie@2.4.3
# | | `-- psl@1.1.31
# | +-- tunnel-agent@0.6.0
# | `-- uuid@3.3.2
# +-- istanbul@0.4.5
# | +-- abbrev@1.0.9
# | +-- async@1.5.2
# | +-- escodegen@1.8.1
# | | +-- esprima@2.7.3
# | | +-- estraverse@1.9.3
# | | +-- optionator@0.8.2
# | | | +-- deep-is@0.1.3
# | | | +-- fast-levenshtein@2.0.6
# | | | +-- prelude-ls@1.1.2
# | | | `-- type-check@0.3.2
# | | `-- source-map@0.2.0
# | | `-- amdefine@1.0.1
# | +-- esprima@2.7.3
# | +-- glob@5.0.15
# | +-- handlebars@4.1.2
# | | +-- neo-async@2.6.0
# | | +-- source-map@0.6.1
# | | `-- uglify-js@3.5.7
# | | `-- source-map@0.6.1
# | +-- nopt@3.0.6
# | +-- once@1.4.0
# | | `-- wrappy@1.0.2
# | +-- resolve@1.1.7
# | +-- supports-color@3.2.3
# | | `-- has-flag@1.0.0
# | +-- which@1.3.1
# | | `-- isexe@2.0.0
# | `-- wordwrap@1.0.0
# +-- karma@3.1.4
# | +-- bluebird@3.5.4
# | +-- body-parser@1.18.3
# | | +-- bytes@3.0.0
# | | +-- content-type@1.0.4
# | | +-- debug@2.6.9
# | | | `-- ms@2.0.0
# | | +-- depd@1.1.2
# | | +-- http-errors@1.6.3
# | | | +-- setprototypeof@1.1.0
# | | | `-- statuses@1.5.0
# | | +-- iconv-lite@0.4.23
# | | | `-- safer-buffer@2.1.2
# | | +-- on-finished@2.3.0
# | | | `-- ee-first@1.1.1
# | | +-- raw-body@2.3.3
# | | | `-- unpipe@1.0.0
# | | `-- type-is@1.6.16
# | | `-- media-typer@0.3.0
# | +-- colors@1.3.3
# | +-- combine-lists@1.0.1
# | +-- connect@3.6.6
# | | +-- finalhandler@1.1.0
# | | | +-- encodeurl@1.0.2
# | | | +-- escape-html@1.0.3
# | | | `-- statuses@1.3.1
# | | +-- parseurl@1.3.3
# | | `-- utils-merge@1.0.1
# | +-- core-js@2.6.5
# | +-- di@0.0.1
# | +-- dom-serialize@2.2.1
# | | +-- custom-event@1.0.1
# | | +-- ent@2.2.0
# | | `-- void-elements@2.0.1
# | +-- expand-braces@0.1.2
# | | +-- array-slice@0.2.3
# | | +-- array-unique@0.2.1
# | | `-- braces@0.1.5
# | | `-- expand-range@0.1.1
# | | +-- is-number@0.1.1
# | | `-- repeat-string@0.2.2
# | +-- flatted@2.0.0
# | +-- graceful-fs@4.1.15
# | +-- http-proxy@1.17.0
# | | +-- eventemitter3@3.1.0
# | | +-- follow-redirects@1.7.0
# | | | `-- debug@3.2.6
# | | `-- requires-port@1.0.0
# | +-- isbinaryfile@3.0.3
# | | `-- buffer-alloc@1.2.0
# | | +-- buffer-alloc-unsafe@1.1.0
# | | `-- buffer-fill@1.0.0
# | +-- log4js@3.0.6
# | | +-- circular-json@0.5.9
# | | +-- date-format@1.2.0
# | | +-- debug@3.2.6
# | | +-- rfdc@1.1.2
# | | `-- streamroller@0.7.0
# | | `-- debug@3.2.6
# | +-- mime@2.4.2
# | +-- minimatch@3.0.4
# | | `-- brace-expansion@1.1.11
# | | +-- balanced-match@1.0.0
# | | `-- concat-map@0.0.1
# | +-- optimist@0.6.1
# | | `-- wordwrap@0.0.3
# | +-- qjobs@1.2.0
# | +-- range-parser@1.2.0
# | +-- safe-buffer@5.1.2
# | +-- socket.io@2.1.1
# | | +-- debug@3.1.0
# | | | `-- ms@2.0.0
# | | +-- engine.io@3.2.1
# | | | +-- accepts@1.3.5
# | | | | `-- negotiator@0.6.1
# | | | +-- base64id@1.0.0
# | | | +-- cookie@0.3.1
# | | | +-- debug@3.1.0
# | | | | `-- ms@2.0.0
# | | | +-- engine.io-parser@2.1.3
# | | | | +-- after@0.8.2
# | | | | +-- arraybuffer.slice@0.0.7
# | | | | `-- blob@0.0.5
# | | | `-- ws@3.3.3
# | | | +-- async-limiter@1.0.0
# | | | `-- ultron@1.1.1
# | | +-- has-binary2@1.0.3
# | | | `-- isarray@2.0.1
# | | +-- socket.io-adapter@1.1.1
# | | +-- socket.io-client@2.1.1
# | | | +-- backo2@1.0.2
# | | | +-- base64-arraybuffer@0.1.5
# | | | +-- component-bind@1.0.0
# | | | +-- component-emitter@1.2.1
# | | | +-- debug@3.1.0
# | | | | `-- ms@2.0.0
# | | | +-- engine.io-client@3.2.1
# | | | | +-- component-emitter@1.2.1
# | | | | +-- component-inherit@0.0.3
# | | | | +-- debug@3.1.0
# | | | | | `-- ms@2.0.0
# | | | | +-- xmlhttprequest-ssl@1.5.5
# | | | | `-- yeast@0.1.2
# | | | +-- has-cors@1.1.0
# | | | +-- object-component@0.0.3
# | | | +-- parseqs@0.0.5
# | | | | `-- better-assert@1.0.2
# | | | | `-- callsite@1.0.0
# | | | +-- parseuri@0.0.5
# | | | `-- to-array@0.1.4
# | | `-- socket.io-parser@3.2.0
# | | +-- component-emitter@1.2.1
# | | +-- debug@3.1.0
# | | | `-- ms@2.0.0
# | | `-- isarray@2.0.1
# | +-- source-map@0.6.1
# | +-- tmp@0.0.33
# | | `-- os-tmpdir@1.0.2
# | `-- useragent@2.3.0
# | `-- lru-cache@4.1.5
# | +-- pseudomap@1.0.2
# | `-- yallist@2.1.2
# +-- karma-chai@0.1.0
# +-- karma-mocha@1.3.0
# | `-- minimist@1.2.0
# +-- mocha@5.2.0
# | +-- browser-stdout@1.3.1
# | +-- commander@2.15.1
# | +-- debug@3.1.0
# | | `-- ms@2.0.0
# | +-- diff@3.5.0
# | +-- escape-string-regexp@1.0.5
# | +-- glob@7.1.2
# | +-- he@1.1.1
# | `-- supports-color@5.4.0
# +-- mocha-lcov-reporter@1.3.0
# +-- ms@2.1.1
# +-- rimraf@2.6.3
# `-- xo@0.23.0
# +-- arrify@1.0.1
# +-- debug@3.2.6
# +-- eslint@5.16.0
# | +-- ajv@6.10.0
# | | +-- fast-deep-equal@2.0.1
# | | +-- fast-json-stable-stringify@2.0.0
# | | +-- json-schema-traverse@0.4.1
# | | `-- uri-js@4.2.2
# | | `-- punycode@2.1.1
# | +-- cross-spawn@6.0.5
# | | +-- nice-try@1.0.5
# | | +-- path-key@2.0.1
# | | `-- shebang-command@1.2.0
# | | `-- shebang-regex@1.0.0
# | +-- debug@4.1.1
# | +-- doctrine@3.0.0
# | +-- eslint-scope@4.0.3
# | | +-- esrecurse@4.2.1
# | | | `-- estraverse@4.2.0
# | | `-- estraverse@4.2.0
# | +-- eslint-utils@1.3.1
# | +-- eslint-visitor-keys@1.0.0
# | +-- espree@5.0.1
# | | `-- acorn-jsx@5.0.1
# | +-- esquery@1.0.1
# | | `-- estraverse@4.2.0
# | +-- file-entry-cache@5.0.1
# | | `-- flat-cache@2.0.1
# | | `-- write@1.0.3
# | +-- functional-red-black-tree@1.0.1
# | +-- ignore@4.0.6
# | +-- import-fresh@3.0.0
# | | `-- parent-module@1.0.1
# | | `-- callsites@3.1.0
# | +-- imurmurhash@0.1.4
# | +-- inquirer@6.3.1
# | | +-- ansi-escapes@3.2.0
# | | +-- cli-cursor@2.1.0
# | | | `-- restore-cursor@2.0.0
# | | | `-- onetime@2.0.1
# | | | `-- mimic-fn@1.2.0
# | | +-- cli-width@2.2.0
# | | +-- external-editor@3.0.3
# | | | +-- chardet@0.7.0
# | | | `-- iconv-lite@0.4.24
# | | +-- figures@2.0.0
# | | +-- mute-stream@0.0.7
# | | +-- run-async@2.3.0
# | | | `-- is-promise@2.1.0
# | | +-- rxjs@6.5.1
# | | | `-- tslib@1.9.3
# | | `-- strip-ansi@5.2.0
# | | `-- ansi-regex@4.1.0
# | +-- json-stable-stringify-without-jsonify@1.0.1
# | +-- levn@0.3.0
# | +-- natural-compare@1.4.0
# | +-- path-is-inside@1.0.2
# | +-- progress@2.0.3
# | +-- regexpp@2.0.1
# | +-- strip-ansi@4.0.0
# | | `-- ansi-regex@3.0.0
# | +-- strip-json-comments@2.0.1
# | +-- table@5.2.3
# | | +-- slice-ansi@2.1.0
# | | | `-- astral-regex@1.0.0
# | | `-- string-width@3.1.0
# | | +-- emoji-regex@7.0.3
# | | `-- strip-ansi@5.2.0
# | | `-- ansi-regex@4.1.0
# | `-- text-table@0.2.0
# +-- eslint-config-prettier@3.6.0
# +-- eslint-config-xo@0.25.1
# +-- eslint-formatter-pretty@1.3.0
# | +-- ansi-escapes@2.0.0
# | +-- log-symbols@2.2.0
# | +-- plur@2.1.2
# | | `-- irregular-plurals@1.4.0
# | `-- string-width@2.1.1
# | `-- is-fullwidth-code-point@2.0.0
# +-- eslint-plugin-ava@5.1.1
# | +-- deep-strict-equal@0.2.0
# | | `-- core-assert@0.2.1
# | | +-- buf-compare@1.0.1
# | | `-- is-error@2.2.2
# | +-- enhance-visitors@1.0.0
# | +-- esm@3.2.22
# | +-- espree@4.1.0
# | +-- espurify@1.8.1
# | | `-- core-js@2.6.5
# | +-- import-modules@1.1.0
# | +-- is-plain-object@2.0.4
# | `-- pkg-up@2.0.0
# +-- eslint-plugin-import@2.17.2
# | +-- array-includes@3.0.3
# | | +-- define-properties@1.1.3
# | | | `-- object-keys@1.1.1
# | | `-- es-abstract@1.13.0
# | | +-- es-to-primitive@1.2.0
# | | | +-- is-date-object@1.0.1
# | | | `-- is-symbol@1.0.2
# | | | `-- has-symbols@1.0.0
# | | +-- is-callable@1.1.4
# | | `-- is-regex@1.0.4
# | +-- contains-path@0.1.0
# | +-- doctrine@1.5.0
# | +-- eslint-import-resolver-node@0.3.2
# | +-- eslint-module-utils@2.4.0
# | | `-- pkg-dir@2.0.0
# | `-- read-pkg-up@2.0.0
# | `-- read-pkg@2.0.0
# | +-- load-json-file@2.0.0
# | | +-- parse-json@2.2.0
# | | `-- pify@2.3.0
# | `-- path-type@2.0.0
# +-- eslint-plugin-no-use-extend-native@0.3.12
# | +-- is-get-set-prop@1.0.0
# | | +-- get-set-props@0.1.0
# | | `-- lowercase-keys@1.0.1
# | +-- is-js-type@2.0.0
# | | `-- js-types@1.0.0
# | +-- is-obj-prop@1.0.0
# | | `-- obj-props@1.1.0
# | `-- is-proto-prop@1.0.1
# | `-- proto-props@1.1.0
# +-- eslint-plugin-node@7.0.1
# | `-- eslint-plugin-es@1.4.0
# +-- eslint-plugin-prettier@2.7.0
# | +-- fast-diff@1.2.0
# | `-- jest-docblock@21.2.0
# +-- eslint-plugin-promise@4.1.1
# +-- eslint-plugin-unicorn@6.0.1
# | +-- clean-regexp@1.0.0
# | +-- eslint-ast-utils@1.1.0
# | | +-- lodash.get@4.4.2
# | | `-- lodash.zip@4.2.0
# | +-- lodash.camelcase@4.3.0
# | +-- lodash.kebabcase@4.1.1
# | +-- lodash.snakecase@4.1.1
# | +-- lodash.upperfirst@4.3.1
# | `-- safe-regex@1.1.0
# | `-- ret@0.1.15
# +-- get-stdin@6.0.0
# +-- globby@8.0.2
# | +-- array-union@1.0.2
# | | `-- array-uniq@1.0.3
# | +-- dir-glob@2.0.0
# | +-- fast-glob@2.2.6
# | | +-- @mrmlnc/readdir-enhanced@2.2.1
# | | | +-- call-me-maybe@1.0.1
# | | | `-- glob-to-regexp@0.3.0
# | | +-- @nodelib/fs.stat@1.1.3
# | | `-- merge2@1.2.3
# | +-- ignore@3.3.10
# | +-- pify@3.0.0
# | `-- slash@1.0.0
# +-- has-flag@3.0.0
# +-- lodash.isequal@4.5.0
# +-- lodash.mergewith@4.6.1
# +-- meow@5.0.0
# | +-- camelcase-keys@4.2.0
# | | +-- camelcase@4.1.0
# | | +-- map-obj@2.0.0
# | | `-- quick-lru@1.1.0
# | +-- decamelize-keys@1.1.0
# | | +-- decamelize@1.2.0
# | | `-- map-obj@1.0.1
# | +-- loud-rejection@1.6.0
# | | +-- currently-unhandled@0.4.1
# | | | `-- array-find-index@1.0.2
# | | `-- signal-exit@3.0.2
# | +-- minimist-options@3.0.2
# | +-- read-pkg-up@3.0.0
# | +-- redent@2.0.0
# | | +-- indent-string@3.2.0
# | | `-- strip-indent@2.0.0
# | +-- trim-newlines@2.0.0
# | `-- yargs-parser@10.1.0
# +-- multimatch@2.1.0
# | `-- array-differ@1.0.0
# +-- open-editor@1.2.0
# | +-- env-editor@0.3.1
# | +-- line-column-path@1.0.0
# | `-- opn@5.5.0
# | `-- is-wsl@1.1.0
# +-- path-exists@3.0.0
# +-- pkg-conf@2.1.0
# | `-- find-up@2.1.0
# | `-- locate-path@2.0.0
# | `-- p-locate@2.0.0
# | `-- p-limit@1.3.0
# | `-- p-try@1.0.0
# +-- prettier@1.17.0
# +-- resolve-cwd@2.0.0
# | `-- resolve-from@3.0.0
# +-- resolve-from@4.0.0
# +-- update-notifier@2.5.0
# | +-- boxen@1.3.0
# | | +-- ansi-align@2.0.0
# | | +-- cli-boxes@1.0.0
# | | +-- term-size@1.2.0
# | | | `-- execa@0.7.0
# | | | `-- cross-spawn@5.1.0
# | | `-- widest-line@2.0.1
# | +-- configstore@3.1.2
# | | +-- dot-prop@4.2.0
# | | | `-- is-obj@1.0.1
# | | +-- make-dir@1.3.0
# | | +-- unique-string@1.0.0
# | | | `-- crypto-random-string@1.0.0
# | | `-- write-file-atomic@2.4.2
# | +-- import-lazy@2.1.0
# | +-- is-ci@1.2.1
# | | `-- ci-info@1.6.0
# | +-- is-installed-globally@0.1.0
# | | +-- global-dirs@0.1.1
# | | | `-- ini@1.3.5
# | | `-- is-path-inside@1.0.1
# | +-- is-npm@1.0.0
# | +-- latest-version@3.1.0
# | | `-- package-json@4.0.1
# | | +-- got@6.7.1
# | | | +-- create-error-class@3.0.2
# | | | | `-- capture-stack-trace@1.0.1
# | | | +-- duplexer3@0.1.4
# | | | +-- is-redirect@1.0.0
# | | | +-- is-retry-allowed@1.1.0
# | | | +-- timed-out@4.0.1
# | | | +-- unzip-response@2.0.1
# | | | `-- url-parse-lax@1.0.0
# | | | `-- prepend-http@1.0.4
# | | +-- registry-auth-token@3.4.0
# | | | `-- rc@1.2.8
# | | | +-- deep-extend@0.6.0
# | | | `-- minimist@1.2.0
# | | `-- registry-url@3.1.0
# | +-- semver-diff@2.1.0
# | `-- xdg-basedir@3.0.0
# `-- xo-init@0.7.0
# +-- execa@0.9.0
# | +-- cross-spawn@5.1.0
# | +-- get-stream@3.0.0
# | +-- is-stream@1.1.0
# | +-- npm-run-path@2.0.2
# | +-- p-finally@1.0.0
# | `-- strip-eof@1.0.0
# +-- has-yarn@1.0.0
# +-- minimist@1.2.0
# +-- read-pkg-up@3.0.0
# +-- the-argv@1.0.0
# `-- write-pkg@3.2.0
# +-- sort-keys@2.0.0
# `-- write-json-file@2.3.0
# `-- detect-indent@5.0.0
# Unexpected platform or architecture: linux/s390x
# It seems there is no binary available for your platform/architecture
# Try to install PhantomJS globally
# npm ERR! Linux 4.4.0-145-generic
# npm ERR! argv "/home/jenkins/.nvs/node/6.15.1/s390x/bin/node" "/home/jenkins/.nvs/node/6.15.1/s390x/bin/npm" "install"
# npm ERR! node v6.15.1
# npm ERR! npm v3.10.10
# npm ERR! code ELIFECYCLE
# npm ERR! phantomjs-prebuilt@2.1.16 install: `node install.js`
# npm ERR! Exit status 1
# npm ERR!
# npm ERR! Failed at the phantomjs-prebuilt@2.1.16 install script 'node install.js'.
# npm ERR! Make sure you have the latest version of node.js and npm installed.
# npm ERR! If you do, this is most likely a problem with the phantomjs-prebuilt package,
# npm ERR! not with npm itself.
# npm ERR! Tell the author that this fails on your system:
# npm ERR! node install.js
# npm ERR! You can get information on how to open an issue for this project with:
# npm ERR! npm bugs phantomjs-prebuilt
# npm ERR! Or if that isn't available, you can get their info via:
# npm ERR! npm owner ls phantomjs-prebuilt
# npm ERR! There is likely additional logging output above.
# npm ERR! Please include the following file with any support request:
# npm ERR! /tmp/b92a2b7c-d6e9-453b-826e-f9b2b359535f/debug/npm-debug.log duration_ms: 41128 ... 1..1