TAP version 13 not ok 1 - mocha v6.1.4 Install Failed ---
# > fsevents@1.2.8 install /private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/fsevents
# > node install
# [fsevents] Success: "/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/fsevents/lib/binding/Release/node-v48-darwin-x64/fse.node" is installed via remote
# > canvas@2.4.1 install /private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas
# > node-pre-gyp install --fallback-to-build
# Failed to execute '/Users/jenkins/.nvs/node/6.16.0/x64/bin/node /Users/jenkins/.nvs/node/6.16.0/x64/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas/build/Release/canvas.node --module_name=canvas --module_path=/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas/build/Release --napi_version=3 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v48' (1)
# mocha@6.1.4 /private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha
# +-- @11ty/eleventy@0.7.1
# | +-- browser-sync@2.26.5
# | | +-- browser-sync-client@2.26.4
# | | | +-- mitt@1.1.3
# | | | `-- rxjs@5.5.12
# | | | `-- symbol-observable@1.0.1
# | | +-- browser-sync-ui@2.26.4
# | | | +-- async-each-series@0.1.1
# | | | +-- socket.io-client@2.2.0
# | | | | +-- debug@3.1.0
# | | | | | `-- ms@2.0.0
# | | | | +-- engine.io-client@3.3.2
# | | | | | +-- debug@3.1.0
# | | | | | | `-- ms@2.0.0
# | | | | | `-- ws@6.1.4
# | | | | `-- socket.io-parser@3.3.0
# | | | | `-- debug@3.1.0
# | | | | `-- ms@2.0.0
# | | | `-- stream-throttle@0.1.3
# | | | `-- limiter@1.1.4
# | | +-- bs-recipes@1.3.4
# | | +-- bs-snippet-injector@2.0.1
# | | +-- connect-history-api-fallback@1.6.0
# | | +-- dev-ip@1.0.1
# | | +-- easy-extender@2.3.4
# | | +-- eazy-logger@3.0.2
# | | | `-- tfunk@3.1.0
# | | | +-- chalk@1.1.3
# | | | | +-- ansi-styles@2.2.1
# | | | | +-- strip-ansi@3.0.1
# | | | | `-- supports-color@2.0.0
# | | | `-- object-path@0.9.2
# | | +-- etag@1.8.1
# | | +-- fresh@0.5.2
# | | +-- fs-extra@3.0.1
# | | | `-- jsonfile@3.0.1
# | | +-- immutable@3.8.2
# | | +-- localtunnel@1.9.1
# | | | +-- axios@0.17.1
# | | | | +-- follow-redirects@1.7.0
# | | | | `-- is-buffer@1.1.6
# | | | +-- debug@2.6.9
# | | | | `-- ms@2.0.0
# | | | +-- openurl@1.1.1
# | | | `-- yargs@6.6.0
# | | | +-- camelcase@3.0.0
# | | | +-- cliui@3.2.0
# | | | | `-- strip-ansi@3.0.1
# | | | +-- get-caller-file@1.0.3
# | | | +-- os-locale@1.4.0
# | | | | `-- lcid@1.0.0
# | | | | `-- invert-kv@1.0.0
# | | | +-- require-main-filename@1.0.1
# | | | +-- string-width@1.0.2
# | | | | `-- is-fullwidth-code-point@1.0.0
# | | | +-- which-module@1.0.0
# | | | +-- y18n@3.2.1
# | | | `-- yargs-parser@4.2.1
# | | +-- opn@5.3.0
# | | | `-- is-wsl@1.1.0
# | | +-- portscanner@2.1.1
# | | | +-- async@1.5.2
# | | | `-- is-number-like@1.0.8
# | | | `-- lodash.isfinite@3.3.2
# | | +-- qs@6.2.3
# | | +-- raw-body@2.4.0
# | | | +-- bytes@3.1.0
# | | | +-- http-errors@1.7.2
# | | | | +-- setprototypeof@1.1.1
# | | | | +-- statuses@1.5.0
# | | | | `-- toidentifier@1.0.0
# | | | +-- iconv-lite@0.4.24
# | | | `-- unpipe@1.0.0
# | | +-- resp-modifier@6.0.2
# | | | `-- debug@2.6.9
# | | | `-- ms@2.0.0
# | | +-- rx@4.1.0
# | | +-- send@0.16.2
# | | | +-- debug@2.6.9
# | | | +-- destroy@1.0.4
# | | | +-- encodeurl@1.0.2
# | | | +-- escape-html@1.0.3
# | | | +-- http-errors@1.6.3
# | | | | `-- setprototypeof@1.1.0
# | | | +-- mime@1.4.1
# | | | +-- ms@2.0.0
# | | | `-- statuses@1.4.0
# | | +-- serve-index@1.9.1
# | | | +-- accepts@1.3.5
# | | | | `-- negotiator@0.6.1
# | | | +-- batch@0.6.1
# | | | +-- debug@2.6.9
# | | | | `-- ms@2.0.0
# | | | `-- http-errors@1.6.3
# | | | +-- setprototypeof@1.1.0
# | | | `-- statuses@1.5.0
# | | +-- serve-static@1.13.2
# | | +-- server-destroy@1.0.1
# | | +-- ua-parser-js@0.7.17
# | | `-- yargs@6.4.0
# | | +-- camelcase@3.0.0
# | | +-- cliui@3.2.0
# | | | `-- strip-ansi@3.0.1
# | | +-- get-caller-file@1.0.3
# | | +-- os-locale@1.4.0
# | | | `-- lcid@1.0.0
# | | | `-- invert-kv@1.0.0
# | | +-- read-pkg-up@1.0.1
# | | | +-- find-up@1.1.2
# | | | | `-- path-exists@2.1.0
# | | | `-- read-pkg@1.1.0
# | | | +-- load-json-file@1.1.0
# | | | | `-- strip-bom@2.0.0
# | | | | `-- is-utf8@0.2.1
# | | | `-- path-type@1.1.0
# | | +-- require-main-filename@1.0.1
# | | +-- string-width@1.0.2
# | | | +-- code-point-at@1.1.0
# | | | `-- is-fullwidth-code-point@1.0.0
# | | +-- which-module@1.0.0
# | | +-- window-size@0.2.0
# | | +-- y18n@3.2.1
# | | `-- yargs-parser@4.2.1
# | +-- chalk@2.4.2
# | | +-- ansi-styles@3.2.1
# | | | `-- color-convert@1.9.3
# | | | `-- color-name@1.1.3
# | | `-- supports-color@5.5.0
# | +-- chokidar@2.1.5
# | | +-- async-each@1.0.3
# | | +-- fsevents@1.2.8
# | | | +-- nan@2.13.2
# | | | `-- node-pre-gyp@0.12.0
# | | | +-- detect-libc@1.0.3
# | | | +-- mkdirp@0.5.1
# | | | | `-- minimist@0.0.8
# | | | +-- needle@2.3.0
# | | | | +-- debug@4.1.1
# | | | | | `-- ms@2.1.1
# | | | | +-- iconv-lite@0.4.24
# | | | | | `-- safer-buffer@2.1.2
# | | | | `-- sax@1.2.4
# | | | +-- nopt@4.0.1
# | | | | +-- abbrev@1.1.1
# | | | | `-- osenv@0.1.5
# | | | | +-- os-homedir@1.0.2
# | | | | `-- os-tmpdir@1.0.2
# | | | +-- npm-packlist@1.4.1
# | | | | +-- ignore-walk@3.0.1
# | | | | | `-- minimatch@3.0.4
# | | | | | `-- brace-expansion@1.1.11
# | | | | | +-- balanced-match@1.0.0
# | | | | | `-- concat-map@0.0.1
# | | | | `-- npm-bundled@1.0.6
# | | | +-- npmlog@4.1.2
# | | | | +-- are-we-there-yet@1.1.5
# | | | | | +-- delegates@1.0.0
# | | | | | `-- readable-stream@2.3.6
# | | | | | +-- core-util-is@1.0.2
# | | | | | +-- isarray@1.0.0
# | | | | | +-- process-nextick-args@2.0.0
# | | | | | +-- string_decoder@1.1.1
# | | | | | `-- util-deprecate@1.0.2
# | | | | +-- console-control-strings@1.1.0
# | | | | +-- gauge@2.7.4
# | | | | | +-- aproba@1.2.0
# | | | | | +-- has-unicode@2.0.1
# | | | | | +-- object-assign@4.1.1
# | | | | | +-- signal-exit@3.0.2
# | | | | | +-- string-width@1.0.2
# | | | | | | +-- code-point-at@1.1.0
# | | | | | | `-- is-fullwidth-code-point@1.0.0
# | | | | | | `-- number-is-nan@1.0.1
# | | | | | +-- strip-ansi@3.0.1
# | | | | | | `-- ansi-regex@2.1.1
# | | | | | `-- wide-align@1.1.3
# | | | | `-- set-blocking@2.0.0
# | | | +-- rc@1.2.8
# | | | | +-- deep-extend@0.6.0
# | | | | +-- ini@1.3.5
# | | | | +-- minimist@1.2.0
# | | | | `-- strip-json-comments@2.0.1
# | | | +-- rimraf@2.6.3
# | | | | `-- glob@7.1.3
# | | | | +-- fs.realpath@1.0.0
# | | | | +-- inflight@1.0.6
# | | | | | `-- wrappy@1.0.2
# | | | | +-- inherits@2.0.3
# | | | | +-- once@1.4.0
# | | | | `-- path-is-absolute@1.0.1
# | | | +-- semver@5.7.0
# | | | `-- tar@4.4.8
# | | | +-- chownr@1.1.1
# | | | +-- fs-minipass@1.2.5
# | | | +-- minipass@2.3.5
# | | | +-- minizlib@1.2.1
# | | | +-- safe-buffer@5.1.2
# | | | `-- yallist@3.0.3
# | | +-- glob-parent@3.1.0
# | | | +-- is-glob@3.1.0
# | | | `-- path-dirname@1.0.2
# | | +-- is-binary-path@1.0.1
# | | | `-- binary-extensions@1.13.1
# | | +-- readdirp@2.2.1
# | | `-- upath@1.1.2
# | +-- debug@4.1.1
# | +-- dependency-tree@6.5.0
# | | +-- debug@4.1.1
# | | +-- filing-cabinet@2.3.2
# | | | +-- app-module-path@2.2.0
# | | | +-- debug@4.1.1
# | | | +-- enhanced-resolve@4.1.0
# | | | | +-- memory-fs@0.4.1
# | | | | `-- tapable@1.1.3
# | | | +-- is-relative-path@1.0.2
# | | | +-- module-definition@3.2.0
# | | | | `-- ast-module-types@2.5.0
# | | | +-- module-lookup-amd@6.2.0
# | | | | +-- debug@4.1.1
# | | | | +-- file-exists-dazinatorfork@1.0.2
# | | | | +-- find@0.3.0
# | | | | | `-- traverse-chain@0.1.0
# | | | | +-- requirejs@2.3.6
# | | | | `-- requirejs-config-file@3.1.2
# | | | | `-- make-dir@2.1.0
# | | | | `-- pify@4.0.1
# | | | +-- resolve-dependency-path@2.0.0
# | | | +-- sass-lookup@3.0.0
# | | | +-- stylus-lookup@3.0.2
# | | | | `-- debug@4.1.1
# | | | `-- typescript@3.4.5
# | | `-- precinct@5.3.1
# | | +-- debug@4.1.1
# | | +-- detective-amd@3.0.0
# | | | +-- escodegen@1.11.1
# | | | | +-- esprima@3.1.3
# | | | | `-- source-map@0.6.1
# | | | `-- get-amd-module-type@3.0.0
# | | +-- detective-cjs@3.1.1
# | | +-- detective-es6@2.1.0
# | | +-- detective-less@1.0.2
# | | | +-- debug@4.1.1
# | | | `-- gonzales-pe@4.2.4
# | | | `-- minimist@1.1.3
# | | +-- detective-postcss@3.0.1
# | | | +-- debug@4.1.1
# | | | +-- is-url@1.2.4
# | | | `-- postcss-values-parser@1.5.0
# | | | +-- flatten@1.0.2
# | | | +-- indexes-of@1.0.1
# | | | `-- uniq@1.0.1
# | | +-- detective-sass@3.0.1
# | | | `-- debug@4.1.1
# | | +-- detective-scss@2.0.1
# | | | `-- debug@4.1.1
# | | +-- detective-stylus@1.0.0
# | | +-- detective-typescript@4.1.2
# | | | `-- typescript-eslint-parser@18.0.0
# | | | +-- lodash.unescape@4.0.1
# | | | `-- semver@5.5.0
# | | `-- node-source-walk@4.2.0
# | +-- ejs@2.6.1
# | +-- fast-glob@2.2.6
# | | +-- @mrmlnc/readdir-enhanced@2.2.1
# | | | +-- call-me-maybe@1.0.1
# | | | `-- glob-to-regexp@0.3.0
# | | +-- @nodelib/fs.stat@1.1.3
# | | `-- merge2@1.2.3
# | +-- fs-extra@7.0.1
# | | +-- jsonfile@4.0.0
# | | `-- universalify@0.1.2
# | +-- gray-matter@4.0.2
# | | +-- kind-of@6.0.2
# | | +-- section-matter@1.0.0
# | | | `-- extend-shallow@2.0.1
# | | `-- strip-bom-string@1.0.0
# | +-- hamljs@0.6.2
# | +-- handlebars@4.1.2
# | | +-- neo-async@2.6.0
# | | +-- source-map@0.6.1
# | | `-- uglify-js@3.5.7
# | | `-- source-map@0.6.1
# | +-- javascript-stringify@1.6.0
# | +-- liquidjs@6.4.3
# | +-- lodash@4.17.11
# | +-- luxon@1.12.1
# | +-- minimist@1.2.0
# | +-- moo@0.5.0
# | +-- multimatch@3.0.0
# | | +-- array-differ@2.1.0
# | | `-- array-union@1.0.2
# | | `-- array-uniq@1.0.3
# | +-- mustache@2.3.2
# | +-- normalize-path@3.0.0
# | +-- nunjucks@3.2.0
# | | +-- a-sync-waterfall@1.0.1
# | | +-- asap@2.0.6
# | | `-- yargs@3.32.0
# | | +-- camelcase@2.1.1
# | | +-- cliui@3.2.0
# | | | `-- strip-ansi@3.0.1
# | | +-- os-locale@1.4.0
# | | | `-- lcid@1.0.0
# | | | `-- invert-kv@1.0.0
# | | +-- string-width@1.0.2
# | | | `-- is-fullwidth-code-point@1.0.0
# | | +-- window-size@0.1.4
# | | `-- y18n@3.2.1
# | +-- parse-filepath@1.0.2
# | | +-- is-absolute@1.0.0
# | | | `-- is-relative@1.0.0
# | | | `-- is-unc-path@1.0.0
# | | | `-- unc-path-regex@0.1.2
# | | +-- map-cache@0.2.2
# | | `-- path-root@0.1.1
# | | `-- path-root-regex@0.1.2
# | +-- please-upgrade-node@3.1.1
# | | `-- semver-compare@1.0.0
# | +-- pretty@2.0.0
# | | +-- condense-newlines@0.2.1
# | | | +-- extend-shallow@2.0.1
# | | | +-- is-whitespace@0.3.0
# | | | `-- kind-of@3.2.2
# | | | `-- is-buffer@1.1.6
# | | +-- extend-shallow@2.0.1
# | | | `-- is-extendable@0.1.1
# | | `-- js-beautify@1.9.1
# | | +-- config-chain@1.1.12
# | | | `-- proto-list@1.2.4
# | | +-- editorconfig@0.15.3
# | | | `-- sigmund@1.0.1
# | | `-- nopt@4.0.1
# | | +-- abbrev@1.1.1
# | | `-- osenv@0.1.5
# | | `-- os-homedir@1.0.2
# | +-- pug@2.0.3
# | | +-- pug-code-gen@2.0.1
# | | | +-- constantinople@3.1.2
# | | | | +-- @types/babel-types@7.0.7
# | | | | +-- @types/babylon@6.16.5
# | | | | +-- babel-types@6.26.0
# | | | | | `-- to-fast-properties@1.0.3
# | | | | `-- babylon@6.18.0
# | | | +-- doctypes@1.1.0
# | | | +-- js-stringify@1.0.2
# | | | +-- pug-attrs@2.0.3
# | | | +-- pug-error@1.3.2
# | | | `-- with@5.1.1
# | | | +-- acorn@3.3.0
# | | | `-- acorn-globals@3.1.0
# | | | `-- acorn@4.0.13
# | | +-- pug-filters@3.1.0
# | | | +-- clean-css@4.2.1
# | | | | `-- source-map@0.6.1
# | | | +-- jstransformer@1.0.0
# | | | +-- pug-walk@1.1.7
# | | | `-- uglify-js@2.8.29
# | | | +-- uglify-to-browserify@1.0.2
# | | | `-- yargs@3.10.0
# | | | +-- camelcase@1.2.1
# | | | +-- cliui@2.1.0
# | | | | +-- center-align@0.1.3
# | | | | | +-- align-text@0.1.4
# | | | | | | +-- kind-of@3.2.2
# | | | | | | | `-- is-buffer@1.1.6
# | | | | | | `-- longest@1.0.1
# | | | | | `-- lazy-cache@1.0.4
# | | | | +-- right-align@0.1.3
# | | | | `-- wordwrap@0.0.2
# | | | `-- window-size@0.1.0
# | | +-- pug-lexer@4.0.0
# | | | +-- character-parser@2.2.0
# | | | `-- is-expression@3.0.0
# | | | `-- acorn@4.0.13
# | | +-- pug-linker@3.0.5
# | | +-- pug-load@2.0.11
# | | +-- pug-parser@5.0.0
# | | | `-- token-stream@0.0.1
# | | +-- pug-runtime@2.0.4
# | | `-- pug-strip-comments@1.0.3
# | +-- recursive-copy@2.0.10
# | | +-- del@2.2.2
# | | | `-- globby@5.0.0
# | | +-- emitter-mixin@0.0.3
# | | +-- errno@0.1.7
# | | | `-- prr@1.0.1
# | | +-- junk@1.0.3
# | | +-- maximatch@0.1.0
# | | | `-- array-differ@1.0.0
# | | +-- pify@2.3.0
# | | +-- promise@7.3.1
# | | `-- slash@1.0.0
# | +-- semver@5.7.0
# | +-- slugify@1.3.4
# | +-- time-require@0.1.2
# | | +-- chalk@0.4.0
# | | | +-- ansi-styles@1.0.0
# | | | +-- has-color@0.1.7
# | | | `-- strip-ansi@0.1.1
# | | +-- date-time@0.1.1
# | | `-- pretty-ms@0.2.2
# | | `-- parse-ms@0.1.2
# | `-- valid-url@1.0.9
# +-- @mocha/contributors@1.0.3
# | +-- parse-author@2.0.0
# | | `-- author-regex@1.0.0
# | +-- pkg-up@2.0.0
# | | `-- find-up@2.1.0
# | | `-- locate-path@2.0.0
# | | `-- p-locate@2.0.0
# | | `-- p-limit@1.3.0
# | | `-- p-try@1.0.0
# | +-- write-pkg@3.2.0
# | | +-- sort-keys@2.0.0
# | | `-- write-json-file@2.3.0
# | | +-- detect-indent@5.0.0
# | | +-- make-dir@1.3.0
# | | +-- pify@3.0.0
# | | `-- write-file-atomic@2.4.2
# | `-- yargs@12.0.5
# | +-- get-caller-file@1.0.3
# | +-- require-main-filename@1.0.1
# | `-- yargs-parser@11.1.1
# +-- @mocha/docdash@2.1.0
# | `-- taffydb@2.7.3
# +-- ansi-colors@3.2.3
# +-- autoprefixer@9.5.1
# | +-- browserslist@4.5.5
# | | +-- electron-to-chromium@1.3.127
# | | `-- node-releases@1.1.17
# | +-- caniuse-lite@1.0.30000963
# | +-- normalize-range@0.1.2
# | +-- num2fraction@1.2.2
# | +-- postcss@7.0.14
# | | +-- source-map@0.6.1
# | | `-- supports-color@6.1.0
# | `-- postcss-value-parser@3.3.1
# +-- browser-stdout@1.3.1
# +-- browserify@16.2.3
# | +-- assert@1.4.1
# | | `-- util@0.10.3
# | | `-- inherits@2.0.1
# | +-- browser-pack@6.1.0
# | | +-- combine-source-map@0.8.0
# | | | +-- convert-source-map@1.1.3
# | | | +-- inline-source-map@0.6.2
# | | | `-- lodash.memoize@3.0.4
# | | +-- through2@2.0.5
# | | `-- umd@3.0.3
# | +-- browser-resolve@1.11.3
# | | `-- resolve@1.1.7
# | +-- browserify-zlib@0.2.0
# | | `-- pako@1.0.10
# | +-- buffer@5.2.1
# | | +-- base64-js@1.3.0
# | | `-- ieee754@1.1.13
# | +-- cached-path-relative@1.0.2
# | +-- concat-stream@1.6.2
# | | +-- buffer-from@1.1.1
# | | `-- typedarray@0.0.6
# | +-- console-browserify@1.1.0
# | | `-- date-now@0.1.4
# | +-- constants-browserify@1.0.0
# | +-- crypto-browserify@3.12.0
# | | +-- browserify-cipher@1.0.1
# | | | +-- browserify-aes@1.2.0
# | | | | `-- buffer-xor@1.0.3
# | | | +-- browserify-des@1.0.2
# | | | | `-- des.js@1.0.0
# | | | `-- evp_bytestokey@1.0.3
# | | +-- browserify-sign@4.0.4
# | | | +-- bn.js@4.11.8
# | | | +-- browserify-rsa@4.0.1
# | | | +-- elliptic@6.4.1
# | | | | +-- brorand@1.1.0
# | | | | +-- hash.js@1.1.7
# | | | | +-- hmac-drbg@1.0.1
# | | | | +-- minimalistic-assert@1.0.1
# | | | | `-- minimalistic-crypto-utils@1.0.1
# | | | `-- parse-asn1@5.1.4
# | | | `-- asn1.js@4.10.1
# | | +-- create-ecdh@4.0.3
# | | +-- create-hash@1.2.0
# | | | +-- cipher-base@1.0.4
# | | | +-- md5.js@1.3.5
# | | | | `-- hash-base@3.0.4
# | | | `-- ripemd160@2.0.2
# | | +-- create-hmac@1.1.7
# | | +-- diffie-hellman@5.0.3
# | | | `-- miller-rabin@4.0.1
# | | +-- pbkdf2@3.0.17
# | | +-- public-encrypt@4.0.3
# | | +-- randombytes@2.1.0
# | | `-- randomfill@1.0.4
# | +-- defined@1.0.0
# | +-- deps-sort@2.0.0
# | | `-- through2@2.0.5
# | +-- domain-browser@1.2.0
# | +-- duplexer2@0.1.4
# | +-- events@2.1.0
# | +-- has@1.0.3
# | +-- htmlescape@1.1.1
# | +-- https-browserify@1.0.0
# | +-- inherits@2.0.3
# | +-- insert-module-globals@7.2.0
# | | +-- acorn-node@1.6.2
# | | | +-- UNMET PEER DEPENDENCY acorn@6.1.1
# | | | +-- acorn-dynamic-import@4.0.0
# | | | `-- acorn-walk@6.1.1
# | | +-- is-buffer@1.1.6
# | | +-- through2@2.0.5
# | | `-- undeclared-identifiers@1.1.3
# | | +-- dash-ast@1.0.0
# | | +-- get-assigned-identifiers@1.2.0
# | | `-- simple-concat@1.0.0
# | +-- JSONStream@1.3.5
# | | +-- jsonparse@1.3.1
# | | `-- through@2.3.8
# | +-- labeled-stream-splicer@2.0.1
# | | +-- isarray@2.0.4
# | | `-- stream-splicer@2.0.0
# | +-- module-deps@6.2.0
# | | +-- detective@5.2.0
# | | | `-- minimist@1.2.0
# | | +-- stream-combiner2@1.1.1
# | | `-- through2@2.0.5
# | +-- os-browserify@0.3.0
# | +-- parents@1.0.1
# | | `-- path-platform@0.11.15
# | +-- path-browserify@0.0.1
# | +-- process@0.11.10
# | +-- punycode@1.4.1
# | +-- querystring-es3@0.2.1
# | +-- read-only-stream@2.0.0
# | +-- readable-stream@2.3.6
# | | +-- core-util-is@1.0.2
# | | +-- isarray@1.0.0
# | | +-- process-nextick-args@2.0.0
# | | `-- util-deprecate@1.0.2
# | +-- resolve@1.10.1
# | +-- shasum@1.0.2
# | | +-- json-stable-stringify@0.0.1
# | | `-- sha.js@2.4.11
# | +-- shell-quote@1.6.1
# | | +-- array-filter@0.0.1
# | | +-- array-map@0.0.0
# | | +-- array-reduce@0.0.0
# | | `-- jsonify@0.0.0
# | +-- stream-browserify@2.0.2
# | +-- stream-http@2.8.3
# | | +-- builtin-status-codes@3.0.0
# | | `-- to-arraybuffer@1.0.1
# | +-- string_decoder@1.1.1
# | +-- subarg@1.0.0
# | | `-- minimist@1.2.0
# | +-- syntax-error@1.4.0
# | +-- through2@2.0.5
# | +-- timers-browserify@1.4.2
# | +-- tty-browserify@0.0.1
# | +-- url@0.11.0
# | | +-- punycode@1.3.2
# | | `-- querystring@0.2.0
# | +-- util@0.10.4
# | +-- vm-browserify@1.1.0
# | `-- xtend@4.0.1
# +-- browserify-package-json@1.0.1
# +-- chai@4.2.0
# | +-- assertion-error@1.1.0
# | +-- check-error@1.0.2
# | +-- deep-eql@3.0.1
# | +-- get-func-name@2.0.0
# | +-- pathval@1.1.0
# | `-- type-detect@4.0.8
# +-- coffee-script@1.12.7
# +-- coveralls@3.0.3
# | +-- lcov-parse@0.0.10
# | +-- log-driver@1.2.7
# | +-- minimist@1.2.0
# | `-- request@2.88.0
# | +-- aws-sign2@0.7.0
# | +-- aws4@1.8.0
# | +-- caseless@0.12.0
# | +-- combined-stream@1.0.7
# | | `-- delayed-stream@1.0.0
# | +-- extend@3.0.2
# | +-- forever-agent@0.6.1
# | +-- form-data@2.3.3
# | | `-- asynckit@0.4.0
# | +-- har-validator@5.1.3
# | | `-- har-schema@2.0.0
# | +-- http-signature@1.2.0
# | | +-- assert-plus@1.0.0
# | | +-- jsprim@1.4.1
# | | | +-- extsprintf@1.3.0
# | | | +-- json-schema@0.2.3
# | | | `-- verror@1.10.0
# | | `-- sshpk@1.16.1
# | | +-- asn1@0.2.4
# | | +-- bcrypt-pbkdf@1.0.2
# | | +-- dashdash@1.14.1
# | | +-- ecc-jsbn@0.1.2
# | | +-- getpass@0.1.7
# | | +-- jsbn@0.1.1
# | | `-- tweetnacl@0.14.5
# | +-- is-typedarray@1.0.0
# | +-- isstream@0.1.2
# | +-- json-stringify-safe@5.0.1
# | +-- mime-types@2.1.24
# | | `-- mime-db@1.40.0
# | +-- oauth-sign@0.9.0
# | +-- performance-now@2.1.0
# | +-- qs@6.5.2
# | +-- tough-cookie@2.4.3
# | | +-- psl@1.1.31
# | | `-- punycode@1.4.1
# | +-- tunnel-agent@0.6.0
# | `-- uuid@3.3.2
# +-- cross-env@5.2.0
# | `-- is-windows@1.0.2
# +-- cross-spawn@6.0.5
# | +-- nice-try@1.0.5
# | +-- path-key@2.0.1
# | `-- shebang-command@1.2.0
# | `-- shebang-regex@1.0.0
# +-- debug@3.2.6
# +-- diff@3.5.0
# +-- escape-string-regexp@1.0.5
# +-- eslint@5.16.0
# | +-- @babel/code-frame@7.0.0
# | | `-- @babel/highlight@7.0.0
# | | `-- js-tokens@4.0.0
# | +-- ajv@6.10.0
# | | +-- fast-deep-equal@2.0.1
# | | +-- fast-json-stable-stringify@2.0.0
# | | +-- json-schema-traverse@0.4.1
# | | `-- uri-js@4.2.2
# | | `-- punycode@2.1.1
# | +-- debug@4.1.1
# | +-- doctrine@3.0.0
# | +-- eslint-scope@4.0.3
# | | +-- esrecurse@4.2.1
# | | `-- estraverse@4.2.0
# | +-- eslint-utils@1.3.1
# | +-- eslint-visitor-keys@1.0.0
# | +-- espree@5.0.1
# | | +-- UNMET PEER DEPENDENCY acorn@6.1.1
# | | `-- acorn-jsx@5.0.1
# | +-- esquery@1.0.1
# | +-- esutils@2.0.2
# | +-- file-entry-cache@5.0.1
# | | `-- flat-cache@2.0.1
# | | `-- write@1.0.3
# | +-- functional-red-black-tree@1.0.1
# | +-- globals@11.11.0
# | +-- ignore@4.0.6
# | +-- import-fresh@3.0.0
# | | +-- parent-module@1.0.1
# | | | `-- callsites@3.1.0
# | | `-- resolve-from@4.0.0
# | +-- imurmurhash@0.1.4
# | +-- inquirer@6.3.1
# | | +-- ansi-escapes@3.2.0
# | | +-- cli-cursor@2.1.0
# | | | `-- restore-cursor@2.0.0
# | | | `-- onetime@2.0.1
# | | | `-- mimic-fn@1.2.0
# | | +-- cli-width@2.2.0
# | | +-- external-editor@3.0.3
# | | | `-- chardet@0.7.0
# | | +-- figures@2.0.0
# | | +-- mute-stream@0.0.7
# | | +-- run-async@2.3.0
# | | `-- rxjs@6.5.1
# | | `-- tslib@1.9.3
# | +-- json-stable-stringify-without-jsonify@1.0.1
# | +-- levn@0.3.0
# | | +-- prelude-ls@1.1.2
# | | `-- type-check@0.3.2
# | +-- natural-compare@1.4.0
# | +-- optionator@0.8.2
# | | +-- deep-is@0.1.3
# | | +-- fast-levenshtein@2.0.6
# | | `-- wordwrap@1.0.0
# | +-- path-is-inside@1.0.2
# | +-- progress@2.0.3
# | +-- regexpp@2.0.1
# | +-- strip-ansi@4.0.0
# | | `-- ansi-regex@3.0.0
# | +-- table@5.2.3
# | | +-- slice-ansi@2.1.0
# | | | `-- astral-regex@1.0.0
# | | `-- string-width@3.1.0
# | `-- text-table@0.2.0
# +-- eslint-config-prettier@3.6.0
# | `-- get-stdin@6.0.0
# +-- eslint-config-semistandard@13.0.0
# +-- eslint-config-standard@12.0.0
# +-- eslint-plugin-import@2.17.2
# | +-- array-includes@3.0.3
# | | `-- es-abstract@1.13.0
# | | +-- es-to-primitive@1.2.0
# | | | +-- is-date-object@1.0.1
# | | | `-- is-symbol@1.0.2
# | | +-- is-callable@1.1.4
# | | `-- is-regex@1.0.4
# | +-- contains-path@0.1.0
# | +-- debug@2.6.9
# | | `-- ms@2.0.0
# | +-- doctrine@1.5.0
# | | `-- isarray@1.0.0
# | +-- eslint-import-resolver-node@0.3.2
# | | `-- debug@2.6.9
# | | `-- ms@2.0.0
# | +-- eslint-module-utils@2.4.0
# | | +-- debug@2.6.9
# | | | `-- ms@2.0.0
# | | `-- pkg-dir@2.0.0
# | | `-- find-up@2.1.0
# | | `-- locate-path@2.0.0
# | | `-- p-locate@2.0.0
# | | `-- p-limit@1.3.0
# | | `-- p-try@1.0.0
# | `-- read-pkg-up@2.0.0
# | +-- find-up@2.1.0
# | | `-- locate-path@2.0.0
# | | `-- p-locate@2.0.0
# | | `-- p-limit@1.3.0
# | | `-- p-try@1.0.0
# | `-- read-pkg@2.0.0
# | +-- load-json-file@2.0.0
# | | +-- parse-json@2.2.0
# | | `-- strip-bom@3.0.0
# | `-- path-type@2.0.0
# +-- eslint-plugin-node@8.0.1
# | +-- eslint-plugin-es@1.4.0
# | `-- ignore@5.1.1
# +-- eslint-plugin-prettier@3.0.1
# | `-- prettier-linter-helpers@1.0.0
# | `-- fast-diff@1.2.0
# +-- eslint-plugin-promise@4.1.1
# +-- eslint-plugin-standard@4.0.0
# +-- find-up@3.0.0
# | `-- locate-path@3.0.0
# | +-- p-locate@3.0.0
# | | `-- p-limit@2.2.0
# | | `-- p-try@2.2.0
# | `-- path-exists@3.0.0
# +-- glob@7.1.3
# | +-- fs.realpath@1.0.0
# | +-- inflight@1.0.6
# | | `-- wrappy@1.0.2
# | +-- once@1.4.0
# | `-- path-is-absolute@1.0.1
# +-- growl@1.10.5
# +-- he@1.2.0
# +-- husky@1.3.1
# | +-- cosmiconfig@5.2.0
# | | +-- import-fresh@2.0.0
# | | | +-- caller-path@2.0.0
# | | | | `-- caller-callsite@2.0.0
# | | | | `-- callsites@2.0.0
# | | | `-- resolve-from@3.0.0
# | | +-- is-directory@0.3.1
# | | `-- parse-json@4.0.0
# | | +-- error-ex@1.3.2
# | | | `-- is-arrayish@0.2.1
# | | `-- json-parse-better-errors@1.0.2
# | +-- execa@1.0.0
# | | +-- get-stream@4.1.0
# | | | `-- pump@3.0.0
# | | | `-- end-of-stream@1.4.1
# | | +-- is-stream@1.1.0
# | | +-- npm-run-path@2.0.2
# | | +-- p-finally@1.0.0
# | | +-- signal-exit@3.0.2
# | | `-- strip-eof@1.0.0
# | +-- get-stdin@6.0.0
# | +-- is-ci@2.0.0
# | | `-- ci-info@2.0.0
# | +-- pkg-dir@3.0.0
# | +-- read-pkg@4.0.1
# | | +-- normalize-package-data@2.5.0
# | | | +-- hosted-git-info@2.7.1
# | | | `-- validate-npm-package-license@3.0.4
# | | | +-- spdx-correct@3.1.0
# | | | | `-- spdx-license-ids@3.0.4
# | | | `-- spdx-expression-parse@3.0.0
# | | | `-- spdx-exceptions@2.2.0
# | | +-- parse-json@4.0.0
# | | `-- pify@3.0.0
# | +-- run-node@1.0.0
# | `-- slash@2.0.0
# +-- js-yaml@3.13.1
# | +-- argparse@1.0.10
# | | `-- sprintf-js@1.0.3
# | `-- esprima@4.0.1
# +-- jsdoc@3.5.5
# | +-- babylon@7.0.0-beta.19
# | +-- bluebird@3.5.4
# | +-- catharsis@0.8.9
# | | `-- underscore-contrib@0.3.0
# | | `-- underscore@1.6.0
# | +-- js2xmlparser@3.0.0
# | | `-- xmlcreate@1.0.2
# | +-- klaw@2.0.0
# | +-- marked@0.3.19
# | +-- requizzle@0.2.1
# | | `-- underscore@1.6.0
# | +-- taffydb@2.6.2
# | `-- underscore@1.8.3
# +-- karma@4.1.0
# | +-- body-parser@1.18.3
# | | +-- bytes@3.0.0
# | | +-- content-type@1.0.4
# | | +-- debug@2.6.9
# | | | `-- ms@2.0.0
# | | +-- depd@1.1.2
# | | +-- http-errors@1.6.3
# | | | +-- setprototypeof@1.1.0
# | | | `-- statuses@1.5.0
# | | +-- iconv-lite@0.4.23
# | | | `-- safer-buffer@2.1.2
# | | +-- on-finished@2.3.0
# | | | `-- ee-first@1.1.1
# | | +-- qs@6.5.2
# | | +-- raw-body@2.3.3
# | | `-- type-is@1.6.16
# | | `-- media-typer@0.3.0
# | +-- braces@2.3.2
# | | +-- arr-flatten@1.1.0
# | | +-- array-unique@0.3.2
# | | +-- extend-shallow@2.0.1
# | | +-- fill-range@4.0.0
# | | | +-- extend-shallow@2.0.1
# | | | +-- is-number@3.0.0
# | | | | `-- kind-of@3.2.2
# | | | | `-- is-buffer@1.1.6
# | | | `-- to-regex-range@2.1.1
# | | +-- isobject@3.0.1
# | | +-- repeat-element@1.1.3
# | | +-- snapdragon@0.8.2
# | | | +-- base@0.11.2
# | | | | +-- cache-base@1.0.1
# | | | | | +-- collection-visit@1.0.0
# | | | | | | +-- map-visit@1.0.0
# | | | | | | `-- object-visit@1.0.1
# | | | | | +-- get-value@2.0.6
# | | | | | +-- has-value@1.0.0
# | | | | | | `-- has-values@1.0.0
# | | | | | | `-- kind-of@4.0.0
# | | | | | | `-- is-buffer@1.1.6
# | | | | | +-- set-value@2.0.0
# | | | | | | `-- extend-shallow@2.0.1
# | | | | | +-- union-value@1.0.0
# | | | | | | `-- set-value@0.4.3
# | | | | | | `-- extend-shallow@2.0.1
# | | | | | `-- unset-value@1.0.0
# | | | | | `-- has-value@0.3.1
# | | | | | +-- has-values@0.1.4
# | | | | | `-- isobject@2.1.0
# | | | | | `-- isarray@1.0.0
# | | | | +-- class-utils@0.3.6
# | | | | | +-- arr-union@3.1.0
# | | | | | +-- define-property@0.2.5
# | | | | | `-- static-extend@0.1.2
# | | | | | +-- define-property@0.2.5
# | | | | | `-- object-copy@0.1.0
# | | | | | +-- copy-descriptor@0.1.1
# | | | | | +-- define-property@0.2.5
# | | | | | `-- kind-of@3.2.2
# | | | | | `-- is-buffer@1.1.6
# | | | | +-- define-property@1.0.0
# | | | | | `-- is-descriptor@1.0.2
# | | | | | +-- is-accessor-descriptor@1.0.0
# | | | | | `-- is-data-descriptor@1.0.0
# | | | | `-- pascalcase@0.1.1
# | | | +-- debug@2.6.9
# | | | | `-- ms@2.0.0
# | | | +-- define-property@0.2.5
# | | | | `-- is-descriptor@0.1.6
# | | | | +-- is-accessor-descriptor@0.1.6
# | | | | | `-- kind-of@3.2.2
# | | | | | `-- is-buffer@1.1.6
# | | | | +-- is-data-descriptor@0.1.4
# | | | | | `-- kind-of@3.2.2
# | | | | | `-- is-buffer@1.1.6
# | | | | `-- kind-of@5.1.0
# | | | +-- extend-shallow@2.0.1
# | | | +-- source-map-resolve@0.5.2
# | | | | +-- atob@2.1.2
# | | | | +-- decode-uri-component@0.2.0
# | | | | +-- resolve-url@0.2.1
# | | | | +-- source-map-url@0.4.0
# | | | | `-- urix@0.1.0
# | | | `-- use@3.1.1
# | | +-- snapdragon-node@2.1.1
# | | | +-- define-property@1.0.0
# | | | | `-- is-descriptor@1.0.2
# | | | | +-- is-accessor-descriptor@1.0.0
# | | | | `-- is-data-descriptor@1.0.0
# | | | `-- snapdragon-util@3.0.1
# | | | `-- kind-of@3.2.2
# | | | `-- is-buffer@1.1.6
# | | +-- split-string@3.1.0
# | | `-- to-regex@3.0.2
# | | `-- safe-regex@1.1.0
# | | `-- ret@0.1.15
# | +-- colors@1.3.3
# | +-- connect@3.6.6
# | | +-- debug@2.6.9
# | | | `-- ms@2.0.0
# | | +-- finalhandler@1.1.0
# | | | +-- debug@2.6.9
# | | | | `-- ms@2.0.0
# | | | `-- statuses@1.3.1
# | | +-- parseurl@1.3.3
# | | `-- utils-merge@1.0.1
# | +-- core-js@2.6.5
# | +-- di@0.0.1
# | +-- dom-serialize@2.2.1
# | | +-- custom-event@1.0.1
# | | +-- ent@2.2.0
# | | `-- void-elements@2.0.1
# | +-- flatted@2.0.0
# | +-- graceful-fs@4.1.15
# | +-- http-proxy@1.15.2
# | | +-- eventemitter3@1.2.0
# | | `-- requires-port@1.0.0
# | +-- isbinaryfile@3.0.3
# | | `-- buffer-alloc@1.2.0
# | | +-- buffer-alloc-unsafe@1.1.0
# | | `-- buffer-fill@1.0.0
# | +-- log4js@4.1.0
# | | +-- date-format@2.0.0
# | | +-- debug@4.1.1
# | | +-- rfdc@1.1.2
# | | `-- streamroller@1.0.4
# | | `-- async@2.6.2
# | +-- mime@2.4.2
# | +-- optimist@0.6.1
# | | `-- wordwrap@0.0.3
# | +-- qjobs@1.2.0
# | +-- range-parser@1.2.0
# | +-- safe-buffer@5.1.2
# | +-- socket.io@2.1.1
# | | +-- debug@3.1.0
# | | | `-- ms@2.0.0
# | | +-- engine.io@3.2.1
# | | | +-- base64id@1.0.0
# | | | +-- cookie@0.3.1
# | | | +-- debug@3.1.0
# | | | | `-- ms@2.0.0
# | | | +-- engine.io-parser@2.1.3
# | | | | +-- after@0.8.2
# | | | | +-- arraybuffer.slice@0.0.7
# | | | | `-- blob@0.0.5
# | | | `-- ws@3.3.3
# | | | +-- async-limiter@1.0.0
# | | | `-- ultron@1.1.1
# | | +-- has-binary2@1.0.3
# | | | `-- isarray@2.0.1
# | | +-- socket.io-adapter@1.1.1
# | | +-- socket.io-client@2.1.1
# | | | +-- backo2@1.0.2
# | | | +-- base64-arraybuffer@0.1.5
# | | | +-- component-bind@1.0.0
# | | | +-- component-emitter@1.2.1
# | | | +-- engine.io-client@3.2.1
# | | | | +-- component-inherit@0.0.3
# | | | | +-- ws@3.3.3
# | | | | +-- xmlhttprequest-ssl@1.5.5
# | | | | `-- yeast@0.1.2
# | | | +-- has-cors@1.1.0
# | | | +-- indexof@0.0.1
# | | | +-- object-component@0.0.3
# | | | +-- parseqs@0.0.5
# | | | | `-- better-assert@1.0.2
# | | | | `-- callsite@1.0.0
# | | | +-- parseuri@0.0.5
# | | | `-- to-array@0.1.4
# | | `-- socket.io-parser@3.2.0
# | +-- source-map@0.6.1
# | +-- tmp@0.0.33
# | | `-- os-tmpdir@1.0.2
# | `-- useragent@2.3.0
# | `-- lru-cache@4.1.5
# | +-- pseudomap@1.0.2
# | `-- yallist@2.1.2
# +-- karma-browserify@6.0.0
# | +-- convert-source-map@1.6.0
# | +-- hat@0.0.3
# | +-- js-string-escape@1.0.1
# | `-- os-shim@0.1.3
# +-- karma-chrome-launcher@2.2.0
# | `-- fs-access@1.0.1
# | `-- null-check@1.0.0
# +-- karma-mocha@1.3.0
# | `-- minimist@1.2.0
# +-- karma-mocha-reporter@2.2.5
# | `-- strip-ansi@4.0.0
# | `-- ansi-regex@3.0.0
# +-- karma-sauce-launcher@2.0.2
# | +-- sauce-connect-launcher@1.2.6
# | | +-- adm-zip@0.4.13
# | | +-- async@2.6.2
# | | `-- https-proxy-agent@2.2.1
# | | `-- agent-base@4.2.1
# | | `-- es6-promisify@5.0.0
# | | `-- es6-promise@4.2.6
# | +-- saucelabs@1.5.0
# | `-- selenium-webdriver@4.0.0-alpha.1
# | +-- jszip@3.2.1
# | | +-- lie@3.3.0
# | | | `-- immediate@3.0.6
# | | +-- pako@1.0.10
# | | `-- set-immediate-shim@1.0.1
# | +-- tmp@0.0.30
# | `-- xml2js@0.4.19
# | `-- xmlbuilder@9.0.7
# +-- lint-staged@8.1.5
# | +-- commander@2.20.0
# | +-- dedent@0.7.0
# | +-- del@3.0.0
# | | +-- globby@6.1.0
# | | | `-- pify@2.3.0
# | | +-- is-path-cwd@1.0.0
# | | `-- is-path-in-cwd@1.0.1
# | | `-- is-path-inside@1.0.1
# | +-- find-parent-dir@0.3.0
# | +-- g-status@2.0.2
# | | +-- matcher@1.1.1
# | | `-- simple-git@1.110.0
# | | `-- debug@4.1.1
# | +-- is-glob@4.0.1
# | | `-- is-extglob@2.1.1
# | +-- listr@0.14.3
# | | +-- @samverschueren/stream-to-observable@0.3.0
# | | | `-- any-observable@0.3.0
# | | +-- is-observable@1.1.0
# | | | `-- symbol-observable@1.2.0
# | | +-- is-promise@2.1.0
# | | +-- listr-silent-renderer@1.1.1
# | | +-- listr-verbose-renderer@0.5.0
# | | | +-- date-fns@1.30.1
# | | | `-- figures@2.0.0
# | | +-- p-map@2.1.0
# | | `-- rxjs@6.5.1
# | +-- listr-update-renderer@0.5.0
# | | +-- chalk@1.1.3
# | | | +-- ansi-styles@2.2.1
# | | | +-- has-ansi@2.0.0
# | | | `-- supports-color@2.0.0
# | | +-- cli-truncate@0.2.1
# | | | +-- slice-ansi@0.0.4
# | | | `-- string-width@1.0.2
# | | | +-- is-fullwidth-code-point@1.0.0
# | | | `-- strip-ansi@3.0.1
# | | +-- elegant-spinner@1.0.1
# | | +-- figures@1.7.0
# | | +-- indent-string@3.2.0
# | | +-- log-symbols@1.0.2
# | | +-- log-update@2.3.0
# | | | `-- wrap-ansi@3.0.1
# | | | `-- strip-ansi@4.0.0
# | | | `-- ansi-regex@3.0.0
# | | `-- strip-ansi@3.0.1
# | | `-- ansi-regex@2.1.1
# | +-- micromatch@3.1.10
# | | +-- arr-diff@4.0.0
# | | +-- define-property@2.0.2
# | | | `-- is-descriptor@1.0.2
# | | | +-- is-accessor-descriptor@1.0.0
# | | | `-- is-data-descriptor@1.0.0
# | | +-- extend-shallow@3.0.2
# | | | +-- assign-symbols@1.0.0
# | | | `-- is-extendable@1.0.1
# | | +-- extglob@2.0.4
# | | | +-- define-property@1.0.0
# | | | | `-- is-descriptor@1.0.2
# | | | | +-- is-accessor-descriptor@1.0.0
# | | | | `-- is-data-descriptor@1.0.0
# | | | +-- expand-brackets@2.1.4
# | | | | +-- debug@2.6.9
# | | | | | `-- ms@2.0.0
# | | | | +-- define-property@0.2.5
# | | | | +-- extend-shallow@2.0.1
# | | | | `-- posix-character-classes@0.1.1
# | | | `-- extend-shallow@2.0.1
# | | +-- fragment-cache@0.2.1
# | | +-- nanomatch@1.2.13
# | | `-- regex-not@1.0.2
# | +-- npm-which@3.0.1
# | | `-- npm-path@2.0.4
# | +-- p-map@1.2.0
# | +-- pify@3.0.0
# | +-- staged-git-files@1.1.2
# | +-- string-argv@0.0.2
# | +-- stringify-object@3.3.0
# | | +-- get-own-enumerable-property-symbols@3.0.0
# | | +-- is-obj@1.0.1
# | | `-- is-regexp@1.0.0
# | `-- yup@0.26.10
# | +-- @babel/runtime@7.0.0
# | | `-- regenerator-runtime@0.12.1
# | +-- fn-name@2.0.1
# | +-- property-expr@1.5.1
# | +-- synchronous-promise@2.0.7
# | `-- toposort@2.0.2
# +-- log-symbols@2.2.0
# +-- markdown-it@8.4.2
# | +-- entities@1.1.2
# | +-- linkify-it@2.1.0
# | +-- mdurl@1.0.1
# | `-- uc.micro@1.0.6
# +-- markdown-it-anchor@5.0.2
# +-- markdown-it-attrs@2.3.3
# +-- markdown-it-prism@2.0.1
# | `-- prismjs@1.16.0
# | `-- clipboard@2.0.4
# | +-- good-listener@1.2.2
# | | `-- delegate@3.2.0
# | +-- select@1.1.2
# | `-- tiny-emitter@2.1.0
# +-- markdown-magic@0.1.25
# | +-- deepmerge@1.5.2
# | +-- find-up@2.1.0
# | | `-- locate-path@2.0.0
# | | `-- p-locate@2.0.0
# | | `-- p-limit@1.3.0
# | | `-- p-try@1.0.0
# | +-- fs-extra@1.0.0
# | | +-- jsonfile@2.4.0
# | | `-- klaw@1.3.1
# | +-- globby@6.1.0
# | | +-- object-assign@4.1.1
# | | `-- pinkie-promise@2.0.1
# | | `-- pinkie@2.0.4
# | +-- is-local-path@0.1.6
# | `-- sync-request@3.0.1
# | +-- http-response-object@1.1.0
# | `-- then-request@2.2.0
# | +-- caseless@0.11.0
# | `-- http-basic@2.5.1
# | `-- caseless@0.11.0
# +-- markdown-magic-package-json@2.0.0
# | `-- findup@0.1.5
# | +-- colors@0.6.2
# | `-- commander@2.1.0
# +-- markdown-toc@1.2.0
# | +-- diacritics-map@0.1.0
# | +-- gray-matter@2.1.1
# | | +-- ansi-red@0.1.1
# | | | `-- ansi-wrap@0.1.0
# | | +-- extend-shallow@2.0.1
# | | `-- toml@2.3.6
# | +-- lazy-cache@2.0.2
# | | `-- set-getter@0.1.0
# | | `-- to-object-path@0.3.0
# | | `-- kind-of@3.2.2
# | | `-- is-buffer@1.1.6
# | +-- list-item@1.1.1
# | | +-- expand-range@1.8.2
# | | | `-- fill-range@2.2.4
# | | | +-- is-number@2.1.0
# | | | | `-- kind-of@3.2.2
# | | | | `-- is-buffer@1.1.6
# | | | +-- isobject@2.1.0
# | | | | `-- isarray@1.0.0
# | | | `-- randomatic@3.1.1
# | | | +-- is-number@4.0.0
# | | | `-- math-random@1.0.4
# | | +-- extend-shallow@2.0.1
# | | `-- is-number@2.1.0
# | | `-- kind-of@3.2.2
# | | `-- is-buffer@1.1.6
# | +-- markdown-link@0.1.1
# | +-- minimist@1.2.0
# | +-- mixin-deep@1.3.1
# | | +-- for-in@1.0.2
# | | `-- is-extendable@1.0.1
# | | `-- is-plain-object@2.0.4
# | +-- object.pick@1.3.0
# | +-- remarkable@1.7.1
# | | +-- argparse@0.1.16
# | | | +-- underscore@1.7.0
# | | | `-- underscore.string@2.4.0
# | | `-- autolinker@0.15.3
# | +-- repeat-string@1.6.1
# | `-- strip-color@0.1.0
# +-- markdownlint-cli@0.14.1
# | +-- commander@2.9.0
# | | `-- graceful-readlink@1.0.1
# | +-- deep-extend@0.5.1
# | +-- get-stdin@5.0.1
# | +-- lodash.differencewith@4.5.0
# | +-- lodash.flatten@4.4.0
# | +-- markdownlint@0.12.0
# | `-- rc@1.2.8
# | +-- deep-extend@0.6.0
# | +-- ini@1.3.5
# | `-- minimist@1.2.0
# +-- minimatch@3.0.4
# | `-- brace-expansion@1.1.11
# | +-- balanced-match@1.0.0
# | `-- concat-map@0.0.1
# +-- mkdirp@0.5.1
# | `-- minimist@0.0.8
# +-- ms@2.1.1
# +-- node-environment-flags@1.0.5
# | `-- object.getownpropertydescriptors@2.0.3
# +-- nps@5.9.5
# | +-- arrify@1.0.1
# | +-- common-tags@1.8.0
# | +-- find-up@2.1.0
# | | `-- locate-path@2.0.0
# | | `-- p-locate@2.0.0
# | | `-- p-limit@1.3.0
# | | `-- p-try@1.0.0
# | +-- manage-path@2.0.0
# | +-- prefix-matches@1.0.1
# | | +-- is-object@1.0.1
# | | `-- starts-with@1.0.2
# | +-- readline-sync@1.4.9
# | +-- spawn-command-with-kill@1.0.2
# | | +-- ps-tree@1.2.0
# | | | `-- event-stream@3.3.4
# | | | +-- duplexer@0.1.1
# | | | +-- from@0.1.7
# | | | +-- map-stream@0.1.0
# | | | +-- pause-stream@0.0.11
# | | | +-- split@0.3.3
# | | | `-- stream-combiner@0.0.4
# | | `-- spawn-command@0.0.2-1
# | `-- yargs@8.0.2
# | +-- camelcase@4.1.0
# | +-- cliui@3.2.0
# | | +-- string-width@1.0.2
# | | | `-- is-fullwidth-code-point@1.0.0
# | | `-- strip-ansi@3.0.1
# | +-- get-caller-file@1.0.3
# | +-- os-locale@2.1.0
# | | +-- execa@0.7.0
# | | | +-- cross-spawn@5.1.0
# | | | `-- get-stream@3.0.0
# | | +-- lcid@1.0.0
# | | | `-- invert-kv@1.0.0
# | | `-- mem@1.1.0
# | | `-- mimic-fn@1.2.0
# | +-- read-pkg-up@2.0.0
# | | `-- read-pkg@2.0.0
# | | +-- load-json-file@2.0.0
# | | | `-- strip-bom@3.0.0
# | | `-- path-type@2.0.0
# | +-- require-main-filename@1.0.1
# | +-- y18n@3.2.1
# | `-- yargs-parser@7.0.0
# +-- nyc@13.3.0
# | +-- archy@1.0.0
# | +-- arrify@1.0.1
# | +-- caching-transform@3.0.1
# | | +-- hasha@3.0.0
# | | | `-- is-stream@1.1.0
# | | +-- package-hash@3.0.0
# | | | +-- graceful-fs@4.1.15
# | | | +-- lodash.flattendeep@4.4.0
# | | | `-- release-zalgo@1.0.0
# | | | `-- es6-error@4.1.1
# | | `-- write-file-atomic@2.4.2
# | | `-- imurmurhash@0.1.4
# | +-- convert-source-map@1.6.0
# | | `-- safe-buffer@5.1.2
# | +-- find-cache-dir@2.0.0
# | | +-- commondir@1.0.1
# | | `-- pkg-dir@3.0.0
# | +-- find-up@3.0.0
# | | `-- locate-path@3.0.0
# | | +-- p-locate@3.0.0
# | | | `-- p-limit@2.1.0
# | | | `-- p-try@2.0.0
# | | `-- path-exists@3.0.0
# | +-- foreground-child@1.5.6
# | | `-- cross-spawn@4.0.2
# | | `-- lru-cache@4.1.5
# | | +-- pseudomap@1.0.2
# | | `-- yallist@2.1.2
# | +-- glob@7.1.3
# | | +-- fs.realpath@1.0.0
# | | +-- inflight@1.0.6
# | | | `-- wrappy@1.0.2
# | | +-- inherits@2.0.3
# | | +-- minimatch@3.0.4
# | | | `-- brace-expansion@1.1.11
# | | | +-- balanced-match@1.0.0
# | | | `-- concat-map@0.0.1
# | | +-- once@1.4.0
# | | `-- path-is-absolute@1.0.1
# | +-- istanbul-lib-coverage@2.0.3
# | +-- istanbul-lib-hook@2.0.3
# | | `-- append-transform@1.0.0
# | | `-- default-require-extensions@2.0.0
# | | `-- strip-bom@3.0.0
# | +-- istanbul-lib-instrument@3.2.0
# | | +-- @babel/generator@7.4.0
# | | | +-- jsesc@2.5.2
# | | | `-- trim-right@1.0.1
# | | +-- @babel/parser@7.4.3
# | | +-- @babel/template@7.4.0
# | | +-- @babel/traverse@7.4.3
# | | | +-- @babel/helper-function-name@7.1.0
# | | | | `-- @babel/helper-get-function-arity@7.0.0
# | | | +-- @babel/helper-split-export-declaration@7.4.0
# | | | `-- debug@4.1.1
# | | +-- @babel/types@7.4.0
# | | | `-- to-fast-properties@2.0.0
# | | +-- istanbul-lib-coverage@2.0.4
# | | `-- semver@6.0.0
# | +-- istanbul-lib-report@2.0.4
# | | `-- supports-color@6.1.0
# | | `-- has-flag@3.0.0
# | +-- istanbul-lib-source-maps@3.0.2
# | | +-- debug@4.1.1
# | | | `-- ms@2.1.1
# | | `-- source-map@0.6.1
# | +-- istanbul-reports@2.1.1
# | | `-- handlebars@4.1.0
# | | +-- async@2.6.2
# | | | `-- lodash@4.17.11
# | | +-- optimist@0.6.1
# | | | +-- minimist@0.0.10
# | | | `-- wordwrap@0.0.3
# | | +-- source-map@0.6.1
# | | `-- uglify-js@3.4.9
# | | +-- commander@2.17.1
# | | `-- source-map@0.6.1
# | +-- make-dir@1.3.0
# | | `-- pify@3.0.0
# | +-- merge-source-map@1.1.0
# | | `-- source-map@0.6.1
# | +-- resolve-from@4.0.0
# | +-- rimraf@2.6.3
# | +-- signal-exit@3.0.2
# | +-- spawn-wrap@1.4.2
# | | +-- mkdirp@0.5.1
# | | | `-- minimist@0.0.8
# | | +-- os-homedir@1.0.2
# | | `-- which@1.3.1
# | | `-- isexe@2.0.0
# | +-- test-exclude@5.1.0
# | | +-- read-pkg-up@4.0.0
# | | | `-- read-pkg@3.0.0
# | | | +-- load-json-file@4.0.0
# | | | | `-- parse-json@4.0.0
# | | | | +-- error-ex@1.3.2
# | | | | | `-- is-arrayish@0.2.1
# | | | | `-- json-parse-better-errors@1.0.2
# | | | +-- normalize-package-data@2.5.0
# | | | | +-- hosted-git-info@2.7.1
# | | | | +-- resolve@1.10.0
# | | | | | `-- path-parse@1.0.6
# | | | | +-- semver@5.6.0
# | | | | `-- validate-npm-package-license@3.0.4
# | | | | +-- spdx-correct@3.1.0
# | | | | | `-- spdx-license-ids@3.0.3
# | | | | `-- spdx-expression-parse@3.0.0
# | | | | `-- spdx-exceptions@2.2.0
# | | | `-- path-type@3.0.0
# | | `-- require-main-filename@1.0.1
# | +-- uuid@3.3.2
# | +-- yargs@12.0.5
# | | +-- cliui@4.1.0
# | | | +-- strip-ansi@4.0.0
# | | | | `-- ansi-regex@3.0.0
# | | | `-- wrap-ansi@2.1.0
# | | | +-- string-width@1.0.2
# | | | | +-- code-point-at@1.1.0
# | | | | `-- is-fullwidth-code-point@1.0.0
# | | | | `-- number-is-nan@1.0.1
# | | | `-- strip-ansi@3.0.1
# | | | `-- ansi-regex@2.1.1
# | | +-- decamelize@1.2.0
# | | +-- get-caller-file@1.0.3
# | | +-- os-locale@3.1.0
# | | | +-- execa@1.0.0
# | | | | +-- cross-spawn@6.0.5
# | | | | | +-- nice-try@1.0.5
# | | | | | +-- path-key@2.0.1
# | | | | | `-- shebang-command@1.2.0
# | | | | | `-- shebang-regex@1.0.0
# | | | | +-- get-stream@4.1.0
# | | | | | `-- pump@3.0.0
# | | | | | `-- end-of-stream@1.4.1
# | | | | +-- npm-run-path@2.0.2
# | | | | +-- p-finally@1.0.0
# | | | | `-- strip-eof@1.0.0
# | | | +-- lcid@2.0.0
# | | | | `-- invert-kv@2.0.0
# | | | `-- mem@4.1.0
# | | | +-- map-age-cleaner@0.1.3
# | | | | `-- p-defer@1.0.0
# | | | +-- mimic-fn@1.2.0
# | | | `-- p-is-promise@2.0.0
# | | +-- require-directory@2.1.1
# | | +-- set-blocking@2.0.0
# | | +-- string-width@2.1.1
# | | | `-- is-fullwidth-code-point@2.0.0
# | | +-- which-module@2.0.0
# | | `-- y18n@4.0.0
# | `-- yargs-parser@11.1.1
# | `-- camelcase@5.0.0
# +-- object.assign@4.1.0
# | +-- define-properties@1.1.3
# | +-- function-bind@1.1.1
# | +-- has-symbols@1.0.0
# | `-- object-keys@1.1.1
# +-- prettier@1.17.0
# +-- remark@10.0.1
# | +-- remark-parse@6.0.3
# | | +-- collapse-white-space@1.0.4
# | | +-- is-whitespace-character@1.0.2
# | | +-- is-word-character@1.0.2
# | | +-- markdown-escapes@1.0.2
# | | +-- parse-entities@1.2.1
# | | | +-- character-entities@1.2.2
# | | | +-- character-entities-legacy@1.1.2
# | | | +-- character-reference-invalid@1.1.2
# | | | `-- is-alphanumerical@1.0.2
# | | +-- state-toggle@1.0.1
# | | +-- trim@0.0.1
# | | +-- trim-trailing-lines@1.1.1
# | | +-- unherit@1.1.1
# | | +-- unist-util-remove-position@1.1.2
# | | `-- vfile-location@2.0.4
# | +-- remark-stringify@6.0.4
# | | +-- ccount@1.0.3
# | | +-- is-alphanumeric@1.0.0
# | | +-- longest-streak@2.0.2
# | | +-- markdown-table@1.1.2
# | | +-- mdast-util-compact@1.0.2
# | | `-- stringify-entities@1.3.2
# | | `-- character-entities-html4@1.1.2
# | `-- unified@7.1.0
# | +-- @types/unist@2.0.3
# | +-- @types/vfile@3.0.2
# | | +-- @types/node@11.13.7
# | | `-- @types/vfile-message@1.0.1
# | +-- bail@1.0.3
# | +-- is-plain-obj@1.1.0
# | +-- trough@1.0.3
# | `-- x-is-string@0.1.0
# +-- remark-github@7.0.6
# | +-- is-alphabetical@1.0.2
# | +-- is-decimal@1.0.2
# | +-- is-hexadecimal@1.0.2
# | +-- mdast-util-to-string@1.0.5
# | `-- unist-util-visit@1.4.0
# | `-- unist-util-visit-parents@2.0.1
# +-- remark-inline-links@3.1.2
# | +-- mdast-util-definitions@1.2.3
# | `-- unist-util-remove@1.0.1
# | `-- unist-util-is@2.1.2
# +-- rewiremock@3.13.5
# | +-- babel-runtime@6.26.0
# | | `-- regenerator-runtime@0.11.1
# | +-- compare-module-exports@2.1.0
# | +-- lodash.some@4.6.0
# | +-- lodash.template@4.4.0
# | | +-- lodash._reinterpolate@3.0.0
# | | `-- lodash.templatesettings@4.1.0
# | +-- node-libs-browser@2.2.0
# | | +-- buffer@4.9.1
# | | | `-- isarray@1.0.0
# | | +-- events@3.0.0
# | | +-- path-browserify@0.0.0
# | | +-- punycode@1.4.1
# | | +-- timers-browserify@2.0.10
# | | | `-- setimmediate@1.0.5
# | | +-- tty-browserify@0.0.0
# | | +-- util@0.11.1
# | | `-- vm-browserify@0.0.4
# | +-- path-parse@1.0.6
# | +-- wipe-node-cache@2.1.0
# | `-- wipe-webpack-cache@2.1.0
# +-- rimraf@2.6.3
# +-- sinon@7.3.2
# | +-- @sinonjs/commons@1.4.0
# | +-- @sinonjs/formatio@3.2.1
# | +-- @sinonjs/samsam@3.3.1
# | | `-- array-from@2.1.1
# | +-- lolex@4.0.1
# | +-- nise@1.4.10
# | | +-- @sinonjs/text-encoding@0.7.1
# | | +-- just-extend@4.0.2
# | | +-- lolex@2.7.5
# | | `-- path-to-regexp@1.7.0
# | | `-- isarray@0.0.1
# | `-- supports-color@5.5.0
# +-- strip-ansi@5.2.0
# | `-- ansi-regex@4.1.0
# +-- strip-json-comments@2.0.1
# +-- supports-color@6.0.0
# | `-- has-flag@3.0.0
# +-- svgo@1.2.2
# | +-- coa@2.0.2
# | | +-- @types/q@1.5.2
# | | `-- q@1.5.1
# | +-- css-select@2.0.2
# | | +-- boolbase@1.0.0
# | | +-- css-what@2.1.3
# | | +-- domutils@1.7.0
# | | | +-- dom-serializer@0.1.1
# | | | `-- domelementtype@1.3.1
# | | `-- nth-check@1.0.2
# | +-- css-select-base-adapter@0.1.1
# | +-- css-tree@1.0.0-alpha.28
# | | +-- mdn-data@1.1.4
# | | `-- source-map@0.5.7
# | +-- css-url-regex@1.1.0
# | +-- csso@3.5.1
# | | `-- css-tree@1.0.0-alpha.29
# | +-- object.values@1.1.0
# | +-- sax@1.2.4
# | +-- stable@0.1.8
# | +-- unquote@1.1.1
# | `-- util.promisify@1.0.0
# +-- through2@3.0.1
# +-- to-vfile@5.0.2
# | +-- is-buffer@2.0.3
# | `-- vfile@3.0.1
# | +-- replace-ext@1.0.0
# | +-- unist-util-stringify-position@1.1.2
# | `-- vfile-message@1.1.1
# +-- unexpected@10.40.2
# | +-- array-changes@3.0.1
# | | `-- arraydiff-papandreou@0.1.1-patch1
# | +-- array-changes-async@3.0.1
# | | `-- arraydiff-async@0.2.0
# | +-- detect-indent@3.0.1
# | | +-- get-stdin@4.0.1
# | | +-- minimist@1.2.0
# | | `-- repeating@1.1.3
# | | `-- is-finite@1.0.2
# | | `-- number-is-nan@1.0.1
# | +-- diff@1.1.0
# | +-- greedy-interval-packer@1.2.0
# | +-- leven@2.1.0
# | +-- magicpen@5.12.0
# | | +-- ansi-styles@2.0.0
# | | +-- color-diff@0.1.7
# | | `-- supports-color@1.2.0
# | `-- unexpected-bluebird@2.9.34-longstack2
# +-- unexpected-eventemitter@1.1.3
# +-- unexpected-sinon@10.11.2
# +-- uslug@1.0.4
# | `-- unorm@1.5.0
# +-- watchify@3.11.1
# | +-- anymatch@2.0.0
# | | `-- normalize-path@2.1.1
# | | `-- remove-trailing-separator@1.1.0
# | +-- outpipe@1.1.1
# | `-- through2@2.0.5
# +-- which@1.3.1
# | `-- isexe@2.0.0
# +-- wide-align@1.1.3
# | `-- string-width@2.1.1
# | `-- is-fullwidth-code-point@2.0.0
# +-- yargs@13.2.2
# | +-- cliui@4.1.0
# | | `-- wrap-ansi@2.1.0
# | | +-- string-width@1.0.2
# | | | `-- is-fullwidth-code-point@1.0.0
# | | `-- strip-ansi@3.0.1
# | | `-- ansi-regex@2.1.1
# | +-- get-caller-file@2.0.5
# | +-- os-locale@3.1.0
# | | +-- lcid@2.0.0
# | | | `-- invert-kv@2.0.0
# | | `-- mem@4.3.0
# | | +-- map-age-cleaner@0.1.3
# | | | `-- p-defer@1.0.0
# | | +-- mimic-fn@2.1.0
# | | `-- p-is-promise@2.1.0
# | +-- require-directory@2.1.1
# | +-- require-main-filename@2.0.0
# | +-- set-blocking@2.0.0
# | +-- string-width@3.1.0
# | | +-- emoji-regex@7.0.3
# | | `-- strip-ansi@5.2.0
# | | `-- ansi-regex@4.1.0
# | +-- which-module@2.0.0
# | `-- y18n@4.0.0
# +-- yargs-parser@13.0.0
# | +-- camelcase@5.3.1
# | `-- decamelize@1.2.0
# `-- yargs-unparser@1.5.0
# +-- flat@4.1.0
# `-- yargs@12.0.5
# +-- get-caller-file@1.0.3
# +-- require-main-filename@1.0.1
# `-- yargs-parser@11.1.1
# /bin/sh: pkg-config: command not found
# gyp: Call to 'pkg-config pixman-1 --libs' returned exit status 127 while in binding.gyp. while trying to load binding.gyp
# gyp ERR! configure error
# gyp ERR! stack Error: `gyp` failed with exit code: 1
# gyp ERR! stack at ChildProcess.onCpExit (/Users/jenkins/.nvs/node/6.16.0/x64/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:305:16)
# gyp ERR! stack at emitTwo (events.js:106:13)
# gyp ERR! stack at ChildProcess.emit (events.js:191:7)
# gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
# gyp ERR! System Darwin 17.7.0
# gyp ERR! command "/Users/jenkins/.nvs/node/6.16.0/x64/bin/node" "/Users/jenkins/.nvs/node/6.16.0/x64/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "--fallback-to-build" "--module=/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas/build/Release/canvas.node" "--module_name=canvas" "--module_path=/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas/build/Release" "--napi_version=3" "--node_abi_napi=napi" "--napi_build_version=0" "--node_napi_label=node-v48"
# gyp ERR! cwd /private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas
# gyp ERR! node -v v6.16.0
# gyp ERR! node-gyp -v v3.4.0
# gyp ERR! not ok
# node-pre-gyp ERR! build error
# node-pre-gyp ERR! stack Error: Failed to execute '/Users/jenkins/.nvs/node/6.16.0/x64/bin/node /Users/jenkins/.nvs/node/6.16.0/x64/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas/build/Release/canvas.node --module_name=canvas --module_path=/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas/build/Release --napi_version=3 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v48' (1)
# node-pre-gyp ERR! stack at ChildProcess. (/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
# node-pre-gyp ERR! stack at emitTwo (events.js:106:13)
# node-pre-gyp ERR! stack at ChildProcess.emit (events.js:191:7)
# node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:920:16)
# node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:230:5)
# node-pre-gyp ERR! System Darwin 17.7.0
# node-pre-gyp ERR! command "/Users/jenkins/.nvs/node/6.16.0/x64/bin/node" "/private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
# node-pre-gyp ERR! cwd /private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/node_modules/canvas
# node-pre-gyp ERR! node -v v6.16.0
# node-pre-gyp ERR! node-pre-gyp -v v0.11.0
# node-pre-gyp ERR! not ok
# npm ERR! Darwin 17.7.0
# npm ERR! argv "/Users/jenkins/.nvs/node/6.16.0/x64/bin/node" "/Users/jenkins/.nvs/node/6.16.0/x64/bin/npm" "install"
# npm ERR! node v6.16.0
# npm ERR! npm v3.10.10
# npm ERR! code ELIFECYCLE
# npm ERR! canvas@2.4.1 install: `node-pre-gyp install --fallback-to-build`
# npm ERR! Exit status 1
# npm ERR!
# npm ERR! Failed at the canvas@2.4.1 install script 'node-pre-gyp install --fallback-to-build'.
# npm ERR! Make sure you have the latest version of node.js and npm installed.
# npm ERR! If you do, this is most likely a problem with the canvas package,
# npm ERR! not with npm itself.
# npm ERR! Tell the author that this fails on your system:
# npm ERR! node-pre-gyp install --fallback-to-build
# npm ERR! You can get information on how to open an issue for this project with:
# npm ERR! npm bugs canvas
# npm ERR! Or if that isn't available, you can get their info via:
# npm ERR! npm owner ls canvas
# npm ERR! There is likely additional logging output above.
# npm ERR! Please include the following file with any support request:
# npm ERR! /private/var/folders/c6/w26wd_553cd6bnqkr8vj6fym000lj1/T/a2dd866d-8f8c-488d-9791-32dabd215a6f/mocha/npm-debug.log duration_ms: 213533 ... 1..1